N'afficher que certaines valeurs ds une colonne

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
baldwin
Membre fidèle
Membre fidèle
Messages : 419
Inscrit le : 9 décembre 2006
Version d'Excel : Windows 7. Excel 2016

Message par baldwin » 3 juillet 2017, 17:54

Salut à tous :D

Je suis sur Numbers sur un Ipad

C'est un tableur simplifié, il n'y a donc pas de filtre.

Mais il y a des fonctions.

Je cherche à afficher seulement des valeurs dans une colonne.

Par ex : afficher seulement les données contenant une croix (un x) dans une colonne.

Soit une colonne "fruit" et une colonne "coche" :

Fruit Coche

Pomme
Poire x
Pêche
Banane x
Ananas

Mon but afficher :

Poire
Banane

Quelqu'un pourrait-il me dire qu'elle fonction utiliser et comment ?

Je crois que le principe doit être le même que sur Excel.

Merci d'avance :wink:
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'349
Appréciations reçues : 236
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 29 juillet 2018, 13:57

Bonjour le forum,

Voir le fichier joint.
X.xlsx
(10.25 Kio) Téléchargé 20 fois
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 7'796
Appréciations reçues : 136
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 29 juillet 2018, 14:19

bonjour
sur le fichier de mbbp au cas ou tu aurais des difficultés avec les matricielles
baldwin22.xlsx
(11.36 Kio) Téléchargé 8 fois
cordialement
c'est en cherchant qu'on trouve
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'349
Appréciations reçues : 236
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 29 juillet 2018, 14:28

Re,

Si le "X" est indiqué en colonne A :

=SIERREUR(GAUCHE(SI(LIGNE()-1>NB.SI($D$1:$D$6;"=1");"";INDEX($A$1:$A$6;PETITE.VALEUR(SI($D$1:$D$6=1;LIGNE($A$1:$A$6);"");LIGNE()-1)));CHERCHE("X";SI(LIGNE()-1>NB.SI($D$1:$D$6;"=1");"";INDEX($A$1:$A$6;PETITE.VALEUR(SI($D$1:$D$6=1;LIGNE($A$1:$A$6);"");LIGNE()-1))))-1);"")

Formule matricielle.
X.png
X.png (6.59 Kio) Vu 132 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message