Somme suivant mois annuel

Y compris Power BI, Power Query et toute autre question en lien avec Excel
J
JOJO76
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 25 juillet 2014
Version d'Excel : 2014

Message par JOJO76 » 25 juillet 2014, 16:31

Bonjour,
Mon tableau ce compose de date puis sur une autre colonne de prix de vente.
J'aimerai calculer mon chiffre d'affaire par mois mais je ne trouve pas la formule.

EXEMPLE :
01/01/2014 2 000,00 €
05/01/2014 5 000,00 €
20/01/2014 2 500,00 €
18/02/2014 10 000,00 €
25/02/2014 7 000,00 €
25/03/2014 5 000,00 €
31/03/2014 25 000,00 €
08/04/2014 15 000,00 €

Merci de votre aide.
E
EngueEngue
Membre impliqué
Membre impliqué
Messages : 1'493
Inscrit le : 12 décembre 2013
Version d'Excel : 2010

Message par EngueEngue » 25 juillet 2014, 16:35

Si tes dates sont en A et tes CA en B
Pour janvier
=SOMMEPROD((MOIS(A1:A100)=1)*1*(B1:B100))
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'379
Appréciations reçues : 239
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 27 juillet 2014, 10:00

Bonjour le forum,

C1:C12 : liste des Mois

D1 : =SOMMEPROD((MOIS(A:A)=LIGNE())*(B:B))

A tirer vers le bas.

mbbp
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 15'501
Appréciations reçues : 552
Inscrit le : 27 août 2012
Version d'Excel : 365 Insider

Message par Jean-Eric » 27 juillet 2014, 10:25

Bienvenu,
Un exemple avec un tableau et un TCD.
Cdlt.
jojo76.xlsx
(20.4 Kio) Téléchargé 14 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
J
JOJO76
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 25 juillet 2014
Version d'Excel : 2014

Message par JOJO76 » 28 juillet 2014, 16:57

Merci pour vos réponse.
Pour mon chiffre d'affaire ça marche bien.
Mais pour la rentabilité ca ne marche pas surement car j'ai une formule entre les deux.
Je vous joint ma feuille excel afin de mieux comprendre le problème.
Cordialement.
Rentabilité.xlsx
(70.97 Kio) Téléchargé 13 fois
Avatar du membre
BrunoM45
Membre impliqué
Membre impliqué
Messages : 2'890
Appréciations reçues : 87
Inscrit le : 29 octobre 2011
Version d'Excel : 2016 FR, O365 FR
Contact :

Message par BrunoM45 » 28 juillet 2014, 17:13

Bonjour Jojo76

Le problème vient de ta formule dans la colonne K
=SI(OU(E7="";J7="");"";E7-J7)
est à remplacer par
=SI(OU(E7="";J7="");0;E7-J7)
A+
[F1] est une touche qui appelle l'aide : Essayez, c'est assez performant et on trouve plein de choses

Il n'y a ni bon ni mauvais usage de la liberté d'expression, il n'en existe qu'un usage insuffisant.
J
JOJO76
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 25 juillet 2014
Version d'Excel : 2014

Message par JOJO76 » 29 juillet 2014, 12:58

Non justement je met les "" pour éviter que des 0 se mettent sur toute ma colonne.
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 15'501
Appréciations reçues : 552
Inscrit le : 27 août 2012
Version d'Excel : 365 Insider

Message par Jean-Eric » 29 juillet 2014, 13:07

Bonjour,
Tu fais comme le préconise BrunoM45 et tu appliques un format nombre personnalisé à ta colonne du type :
# ##0;-# ##0;
Les zéros ne seront pas affichés.
Cdlt.
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message