Rechercher Valeur dans plage et renvoyer Cellule Haut de la colonne Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
T
Tylerdurden
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 24 janvier 2018
Version d'Excel : Excel 2016

Message par Tylerdurden » 7 février 2018, 14:21

Bonjour,

Soyons concis!

Je souhaite créer une fonction pour que Dans une Plage, si je trouve le Mot que je recherche dans une colonne, La Valeur renvoyée soit la premiere ligne de ma colonne.

Donc SI "AFA" est dans la colonne 3 de ma plage, la fonction renvoie ce qu'il y a dans C1.

Merci d'avance.
Affecter Cellule si dans cellule.xlsx
(8.1 Kio) Téléchargé 16 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 7 février 2018, 14:27

Bonjour le forum,
=SI(NB.SI(A2:A5;B11)>0;A1;"")
T
Tylerdurden
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 24 janvier 2018
Version d'Excel : Excel 2016

Message par Tylerdurden » 7 février 2018, 14:37

Pardon, j'ai dû mal m'exprimer,

Je souhaite que n’importe que cela fonctionne pour n'importe quelle valeur de ma plage et que la valeur renvoyée soit la première ligne de la colonne ou j'ai trouvé ma cellule.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 7 février 2018, 14:48

bonjour
normalement
tyler dur.xlsx
(8.46 Kio) Téléchargé 25 fois
a condition que la val ne soit presente qu'une fois , sinon ce n'est pas la meme formule
teste
cordialement
1 membre du forum aime ce message.
c'est en cherchant qu'on trouve
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 7 février 2018, 14:58

Bonjour le forum,
=SI(MAX(SI(A1:G5=I1;COLONNE(A1:G5)))=0;"";INDEX(A1:G1;MAX(SI(A1:G5=I1;COLONNE(A1:G5)))))
Formule matricielle.
INDEX.png
INDEX.png (6.95 Kio) Vu 403 fois
Modifié en dernier par mbbp le 7 février 2018, 15:11, modifié 1 fois.
1 membre du forum aime ce message.
T
Tylerdurden
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 24 janvier 2018
Version d'Excel : Excel 2016

Message par Tylerdurden » 7 février 2018, 15:07

Merci énormément Tulipe. Je vas pouvoir respecter ma deadline.

Petite proposition, essayez de mettre vos comptes Tipee, j'aimerais pouvoir remercier autrement que par des mots
les gens qui aident.

Amicalement. ::D
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 7 février 2018, 15:10

Supprimé
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message