RECHERCHE avec plusieurs résultats

Y compris Power BI, Power Query et toute autre question en lien avec Excel
L
LAMY001
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 25 février 2016
Version d'Excel : 2013

Message par LAMY001 » 25 février 2016, 16:47

bonjour,

merci de me venir en aide je suis totalement bloquée
ECART 01.xlsx
(54.35 Kio) Téléchargé 10 fois
!!! j'ai une base de donnée avec 3 colonnes l'article, la quantité et le prix sur ma feuille je dois trouver pour chaque article la quantité et le prix qui correspond j'ai utiliser la fonction "recherchev" mais elle ne renvoie qu'un seul résultat alors que j'ai plusieurs résultats par article.
J'aimerai savoir comment faire pour renvoyer les autres réponses en cas de réponse multiple.

mon fichier est ci-joint

Je remercie par avance la personne qui viendra à mon secours.
L
LAMY001
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 25 février 2016
Version d'Excel : 2013

Message par LAMY001 » 25 février 2016, 17:08

HEEEELP PLLLLLLZZ je dois rendre le travail demain :? :? :? :?
p
patrick1957
Passionné d'Excel
Passionné d'Excel
Messages : 3'122
Appréciations reçues : 32
Inscrit le : 24 août 2015
Version d'Excel : 2007-2010-2016 PC

Message par patrick1957 » 25 février 2016, 17:54

Bonjour,


déjà utilisation des cellules fusionnées proscrites, ça fout la m...

Pour le reste il y a des choses à revoir aussi, j'y regarde un peu , mais je ne suis pas seul surement :) (et j'espère)

P.

et... 10 colonnes d'un côté et 7 de l'autre, ce n'est pas 3 colonnes !

et tes explications laissent à désirer, mais..je suis dur de la comprenette souvent :)
Je fais du géocaching et vous ?
Indentez vos codes VBA, ---> http://www.oaltd.co.uk/Indenter/Default.htm
A lire pour les débutants: http://www.xlerateur.com/divers/2010/05 ... nnees-612/
L
LAMY001
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 25 février 2016
Version d'Excel : 2013

Message par LAMY001 » 25 février 2016, 18:17

voila j'ai modifié le fichier j'espère que c plus claire ! je veux afficher sur la feuille4 pour chaque article le prix et la quantité
ECART 01.xlsx
(32.44 Kio) Téléchargé 68 fois
p
patrick1957
Passionné d'Excel
Passionné d'Excel
Messages : 3'122
Appréciations reçues : 32
Inscrit le : 24 août 2015
Version d'Excel : 2007-2010-2016 PC

Message par patrick1957 » 25 février 2016, 18:50

re,

si tu veux les quantités * prix pour article G1606, ---> en D3 : =SOMMEPROD((QUANTITE)*(PRIX)*(A3=nom))

qui ne donne pas ton total de 136.446 €

et enlève ces foutues cellules fusionnées...enfin c'est toi qui voit mais c'est toujours source de problème


P.
Je fais du géocaching et vous ?
Indentez vos codes VBA, ---> http://www.oaltd.co.uk/Indenter/Default.htm
A lire pour les débutants: http://www.xlerateur.com/divers/2010/05 ... nnees-612/
L
LAMY001
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 25 février 2016
Version d'Excel : 2013

Message par LAMY001 » 26 février 2016, 09:55

GRAND MERCI LES AMIS POUR VOTRE AIDE
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message