Cumuler des valeurs selon d'autres

Bonjour,

Je bloque sur un problème de cumul. Et je sollicite votre aide s'il vous plait.

J'ai 3 colonnes, une colonne qui contient des données A, une colonne qui contient des données B et ma 3ème colonne qui doit cumuler les données en B selon les données en A.

Voir fichier ci-joint pour plus de clarté

Merci pour votre contribution.

Bonsoir,

Une proposition.

Cordialement.

Bonjour le forum,

1er tableau :

D5 :

=SOMME.SI.ENS($C$5:C5;$B$5:B5;B5)

A tirer vers le bas.

2ème tableau :

B22 : =TRANSPOSE(D5:D13)

Formule matricielle.

A tirer vers la droite.

Bonsoir,

Voir dans le fichier en retour.

Re,

Image jointe :

transpose

Bonjour à tous,

Merci à vous pour votre collaboration : [Zebulon], mbbp et Raja.

Ça fonctionne nickel.

J'ai pourtant essayé avec Somme.si et Sommeprod mais je compliquais les formules.

Je ne pensais pas que Somme.si.ens ou somme.si pouvais faire un cumul sur des lignes ou colonnes différentes.

Par contre, pour info pour mbbp avec Transpose - intéressant mais que je ne connaissais pas d'ailleurs - cela ne fonctionne pas.

Merci encore,

Re,

Merci Rundle pour ton retour.

Toujours avec TRANSPOSER :

1transposer.xlsx (10.67 Ko)

Rechercher des sujets similaires à "cumuler valeurs"