Formule pointage compétition

Bonjour,

J'ai besoin d'aide pour une formule Excel. C'est pour les résultats d'une compétition d'athlétisme.

Le pointage est attribué selon le rang qui est inscrit dans une cellule.

Le 1er rang vaut 9 points

Le 2e, 7 pts

Le 3e, 6 pts

Le 4e, 5 pts

Le 5e, 4 pts

Le 6e, 3 pts

Le 7e, 2pts

Le 8e, 1 pt

* Il n'y a pas de rang 9e.

Alors, pour le point du 2e rang au 8e, la formule suivante fonctionne: = 9- (la cellule du rang) exemple 9-2e rang = 7 points

Mais pour la 1re position, doit attribuer 9 points, ne rien soustraire

Comment je peux ajouter cette condition à la formule?

Merci de m'aider

Bonjour,

Tu peux feinter en faisant la chose suivante :

= 9 - Si(rang=1;0;rang)

Du coup, cela devrait jouer ...pour tous les rangs

Bonjour,

voici un exemple,

Bonjour le fil

Autre proposition :

= CNUM( STXT( 97654321 ; rang ; 1))

où "rang" est à remplacer par le n° de rang ou la cellule le contenant (logique)

CNUM pour convertir en chiffre et STXT pour rechercher les points selon le rang

STXT a pour paramètres

1) le texte dans lequel chercher (mais le type n'est pas forcément du texte) => dans ce cas il s'agit des Points attribués à chaque rang

2) le point de départ de la recherche => ici le rang

3) le nombre de caractère à extraire => ici 1 seul

Bonjour,

Une autre formule !...

Cdlt.

2carob.xlsx (9.23 Ko)
C3 : =RECHERCHEV(B3;{1.9;2.7;3.6;4.5;5.4;6.3;7.2;8.1};2;0)

Bonjour à tous,

J'essaie d'appliquer les formules que vous me proposez, mais je ne comprends pas trop.

Alors voici une partie du tableau que j'avais bâti afin que vous compreniez mieux.

J'ai mis en jaune la cellule où le résultat doit être 9.

Toutefois, il faut que ce soit la même formule à la colonne K puisque les rang ne seront pas en ordre selon les résultats des athlètes.

Merci!

Bonjour Gli73

Merciiiiiiiii !

Ça marche! Bien que je ne comprenne rien de tes explications (désolée, je ne suis pas très calée en informatique).

Bonjour le fil

Autre proposition :

= CNUM( STXT( 97654321 ; rang ; 1))

où "rang" est à remplacer par le n° de rang ou la cellule le contenant (logique)

CNUM pour convertir en chiffre et STXT pour rechercher les points selon le rang

STXT a pour paramètres

1) le texte dans lequel chercher (mais le type n'est pas forcément du texte) => dans ce cas il s'agit des Points attribués à chaque rang

2) le point de départ de la recherche => ici le rang

3) le nombre de caractère à extraire => ici 1 seul

Re,

Je persévère !...

Cdlt.

Re,

Je persévère !...

Cdlt.

Classement_test.xlsx

Merci Jean-Éric!

Bonjour,

une autre pour faire bonne mesure :

=9-J2+(J2=1)

eric

Bonjour,

une autre pour faire bonne mesure :

=9-J2+(J2=1)

eric

Merci beaucoup Éric!

As-tu au moins vu la toute première réponse ... ?

= 9 - Si(rang=1 ; 0 ; rang)

Environ 10 minutes après ta question ...

Bonjour,

une autre pour faire bonne mesure :

=9-J2+(J2=1)

eric

Bonjour Éric,

Un grand merci pour ta formule. Finalement, j'avais mal compris les consignes que la gérante du club d'athlétisme m'a données, il faut inscrire les rangs plus bas que 8. Je suis parent bénévole et je les aide à s'organiser, mais je ne suis pas experte en Excel.

Pour inscrire les rangs, moi, j'avais compris qu'après 8e, on inscrivait 8 partout. Mais non, il faut inscrire 8, 9, 10...

Ça change la formule et je ne sais pas comment faire.

Penses-tu pouvoir m'aider? J'ai mis un tableau en exemple

Merci beaucoup!

re,

formule à mettre en cellule J2

=SI(I3>7;1;CHOISIR(I3;9;7;6;5;4;3;2))

et recopier vers le bas

Bonjour à tous,

ou bien :

=MAX(9-I2+(I2=1);1)

eric

Merci Éric, tu me sauves vraiment la vie... et merci de la part du club d'athétisme de Drummondville [/https://athletismedrummondville.ca/]

Carolyne

Rechercher des sujets similaires à "formule pointage competition"