validation

Y compris Power BI, Power Query et toute autre question en lien avec Excel
z
zakou76
Jeune membre
Jeune membre
Messages : 27
Inscrit le : 4 janvier 2007
Version d'Excel : lecture-sport-bicolage...

Message par zakou76 » 18 décembre 2018, 11:33

Bonjour.
je voudrais savoir comment valider une donnee dependant d'une cellule. Je m'explique:
Dans la colonne A j'ai des villes(Paris,Londre,Berlin, Paris...)
Dans la colonne B je laisse la cellule vide si la ville est "Paris" et pour les autres villes, l'utilisateur doit saisir doit saisir une valeur de 6 chiffres.
Merci pour votre aide.
Le savoir n'est utile que lorsqu'il est partagé.
y
yamitony
Membre habitué
Membre habitué
Messages : 56
Inscrit le : 2 mars 2018
Version d'Excel : 2016

Message par yamitony » 18 décembre 2018, 11:42

Bonjour,
un petit fichier... plus facile pour visualiser ta demande.
Comment sont rentré les autre données si la ville n'est pas paris via un formulaire ou directement sur le fichier ?

Cordialement.
z
zakou76
Jeune membre
Jeune membre
Messages : 27
Inscrit le : 4 janvier 2007
Version d'Excel : lecture-sport-bicolage...

Message par zakou76 » 18 décembre 2018, 11:44

Validation.xlsx
(8.45 Kio) Téléchargé 10 fois
Rebonjour.
Les donnes sont saisies sur une feuille de calcul. Merci
Le savoir n'est utile que lorsqu'il est partagé.
y
yamitony
Membre habitué
Membre habitué
Messages : 56
Inscrit le : 2 mars 2018
Version d'Excel : 2016

Message par yamitony » 18 décembre 2018, 11:49

Quand tu parle de valider des données que souhaite tu faire comme action ?
z
zakou76
Jeune membre
Jeune membre
Messages : 27
Inscrit le : 4 janvier 2007
Version d'Excel : lecture-sport-bicolage...

Message par zakou76 » 18 décembre 2018, 11:53

Je voudrais que l'utilisateur saisit dans la colonne B un chiffre de 6 nombre si la ville est differente de Paris. Et si la ville est Paris l'utilisateur peut saisir toute information(un chiffre, un nombre...)
Le savoir n'est utile que lorsqu'il est partagé.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 18 décembre 2018, 12:38

Bonjour le forum,
zakou76 a écrit :
18 décembre 2018, 11:53
Je voudrais que l'utilisateur saisit dans la colonne B un chiffre de 6 nombre
Très difficile à trouver !
y
yamitony
Membre habitué
Membre habitué
Messages : 56
Inscrit le : 2 mars 2018
Version d'Excel : 2016

Message par yamitony » 18 décembre 2018, 13:57

mbbp,

je veux bien voir ta solution car moi je bloque, j arrive bien à lui faire indiqué la saisie de 6 chiffre obligatoire mais j arrive pas a lui indiquer que si paris est indiqué que n'importe qu'elle choix est possible il me laisse le format de cellule bloqué...

trop pris l'habitude de passé par des macro ou des userform pour faire ce genre de manip que j en oublie les base :/

Cordialement.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 18 décembre 2018, 14:42

bonjour
apres avoir choisi (personalisé)
=SI(A2="paris"; NON(ESTNUM(B2));ESTNUM(B2))
qui ne regle pas pour les 6 chiffres ;mais eventuellement perfectible
cordialement
c'est en cherchant qu'on trouve
z
zakou76
Jeune membre
Jeune membre
Messages : 27
Inscrit le : 4 janvier 2007
Version d'Excel : lecture-sport-bicolage...

Message par zakou76 » 18 décembre 2018, 17:04

Merci mais je n'ai toujours pas de solution et pourtant je suis sur un forum d'expert!!!
Le savoir n'est utile que lorsqu'il est partagé.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 18 décembre 2018, 18:26

re
toujours dans personnalisé
1)impossible de saisir des chiffres si Paris
2)impossible de saisir du texte pour les autres
3)si autre que paris , obligé de saisir 6 chiffres
=SI(A2="paris"; NON(ESTNUM(B2));ET(ESTNUM(B2);NBCAR(B2)=6))
cordialement
c'est en cherchant qu'on trouve
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message