formule pour supprimer les chiffres après le virgule

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
Répondre
t
tinkode
Jeune membre
Jeune membre
Messages : 12
Inscrit le : 21 octobre 2018
Version d'Excel : 2007

Message par tinkode » 21 octobre 2018, 15:20

Hello les rois de la formule <3
Je cherche - et je ne trouve pas :

une formule pour supprimer les chiffres après le virgule & le virgule
Capture.PNG
Capture.PNG (6.13 Kio) Vu 697 fois
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'898
Appréciations reçues : 694
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 21 octobre 2018, 15:25

Bonjour tinkode,

:bv:

je te propose cette formule :

=GAUCHE(A1;CHERCHE(",";A1)-1)

dhany
1 membre du forum aime ce message.
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'898
Appréciations reçues : 694
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 21 octobre 2018, 15:35

complément : le retour de la formule est du texte, et c'est ok si y'a pas de calcul dessus ; par contre, si tu as besoin de faire un calcul dessus, le retour doit être numérique ; pour cela, il te suffit de mettre deux signes moins devant la formule, comme ceci :

=--GAUCHE(A1;CHERCHE(",";A1)-1)

dhany
1 membre du forum aime ce message.
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'898
Appréciations reçues : 694
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 21 octobre 2018, 15:46

ouppps !  :oops:  j'ai pas pensé à utiliser cette formule bien plus simple :

=ENT(A1)

ENT est l'abréviation de partie entière, et le retour est numérique.

utilise cette formule plutôt que les 2 précédentes !  ;;)

mais attention : le résultat est tronqué ! par exemple :  ENT(3,99)  retourne 3 et non 4

tu peux aussi regarder une de ces 3 formules :

=ARRONDI(A1;0)

=ARRONDI.INF(A1;0)

=ARRONDI.SUP(A1;0)

certains retours sont identiques pour des nombres positifs,
mais sont différents pour des nombres négatifs.


à toi de choisir selon l'arrondi que tu préfères.  ;;)

dhany
1 membre du forum aime ce message.
t
tinkode
Jeune membre
Jeune membre
Messages : 12
Inscrit le : 21 octobre 2018
Version d'Excel : 2007

Message par tinkode » 21 octobre 2018, 16:34

Merci d'avoir pris du temps pour moi

=ARRONDI(A1;0)

MERCIIIII ENCORE
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'898
Appréciations reçues : 694
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 21 octobre 2018, 16:57

merci pour ton retour, et pour les  !  :D  :sp:

:btres:
dhany
1 membre du forum aime ce message.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message