Formule NB.SI ???

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
Atomiik Loic
Membre habitué
Membre habitué
Messages : 119
Inscrit le : 7 août 2018
Version d'Excel : 2007

Message par Atomiik Loic » 3 septembre 2018, 19:36

Bonjour à Tous , je pêche sur un programme Excel que je viens de crée , je vous explique :

J'ai créer un planning de congés , maladie etc etc de cette manière :

Un onglet par mois , janvier , février etc etc...

Un onglet Config , et c'est de la que je fais tout mes réglages automatiques . ( et c'est la que je veux ma formule dans le tableau )
la dessus j'ai un récapitulatif de l'année pour chaque employée pour les congés , maladie , récup etc....

Ma question est la suivante :

Quelle formule je dois mettre sachant que je veux comme résultat qu'il me trouve le nombre de ND ( congés non décomptés ) dans chaque feuille , par employée ( donc par ligne ) et dans cette ligne que le nombre de "ND" et ne pas me compter les MA , CP Etc etc ( maladie,congés )

je joins le fichier avec , merci en avance ...
Voici le mot de passe pour les feuilles protégées : lo@de%
Demande Souhait Congés.xlsx
(114.81 Kio) Téléchargé 7 fois
Avatar du membre
Atomiik Loic
Membre habitué
Membre habitué
Messages : 119
Inscrit le : 7 août 2018
Version d'Excel : 2007

Message par Atomiik Loic » 3 septembre 2018, 20:10

Je UP la demande car j'ai trouver la FORMULE mais que pour Janvier , comment faire pour que ça me le calcule toute l'année de Janvier à Décembre ???

=SI(B11="";"";NB.SI(Janvier!F11:AJ11;"ND"))
R
Rag02700
Membre fidèle
Membre fidèle
Messages : 290
Appréciations reçues : 4
Inscrit le : 26 décembre 2017
Version d'Excel : 2010

Message par Rag02700 » 3 septembre 2018, 21:09

Hello,

Tu peux faire comme ça dans la cellule K4 de ton onglet "config" :

=SI(B4="";"";NB.SI(Janvier!F11:AJ11;"ND")+NB.SI(Février!F11:AJ11;"ND"))

Tu fais ça jusque décembre.

A+
Avatar du membre
Atomiik Loic
Membre habitué
Membre habitué
Messages : 119
Inscrit le : 7 août 2018
Version d'Excel : 2007

Message par Atomiik Loic » 3 septembre 2018, 21:33

Rag02700 a écrit :
3 septembre 2018, 21:09
Hello,

Tu peux faire comme ça dans la cellule K4 de ton onglet "config" :

=SI(B4="";"";NB.SI(Janvier!F11:AJ11;"ND")+NB.SI(Février!F11:AJ11;"ND"))

Tu fais ça jusque décembre.

A+
Merci Rag02700 de t'avoir pencher sur ma question , ça marche plutôt pas mal .
Maintenant j'ai un autre soucis c'est que dans ma formule j'ai mis que si B4 est vide alors ne rien écrire en K4 DE MON ONGLET CONFIG sauf qu'il me met ####### #VALEUR

=SI(B4="";"";NB.SI(Janvier!F11:AJ11;"ND"))+NB.SI(Février!F11:AJ11;"ND")+(NB.SI(Mars!F11:AJ11;"ND"))+NB.SI(Avril!F11:AJ11;"ND")+(NB.SI(Mai!F11:AJ11;"ND"))+NB.SI(Juin!F11:AJ11;"ND")+NB.SI(Juillet!F11:AJ11;"ND")+NB.SI(Août!F11:AJ11;"ND")+(NB.SI(Septembre!F11:AJ11;"ND"))+NB.SI(Octobre!F11:AJ11;"ND")+(NB.SI(Novembre!F11:AJ11;"ND"))+NB.SI(Décembre!F11:AJ11;"ND")

Tu saurais pourquoi ?
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'665
Appréciations reçues : 24
Inscrit le : 14 novembre 2012
Version d'Excel : 2016 FR

Message par R@chid » 4 septembre 2018, 02:27

Bonsoir @ tous,
en H4 :
=SOMMEPROD(NB.SI(INDIRECT($D$6:$D$17&"!F"&LIGNE(A11)&":AJ"&LIGNE(A11));H$3))
@ tirer vers le bas et vers la droite


@ + +
2 membres du forum aiment ce message.
"Donnez moi un point d'appui et je soulèverai le monde"
R
Rag02700
Membre fidèle
Membre fidèle
Messages : 290
Appréciations reçues : 4
Inscrit le : 26 décembre 2017
Version d'Excel : 2010

Message par Rag02700 » 4 septembre 2018, 21:06

Hello atomic,

Erreur de syntaxe :

=SI(B4="";"";NB.SI(Janvier!F11:AJ11;"ND")+NB.SI(Février!F11:AJ11;"ND")+(NB.SI(Mars!F11:AJ11;"ND")+NB.SI(Avril!F11:AJ11;"ND")+(NB.SI(Mai!F11:AJ11;"ND")+NB.SI(Juin!F11:AJ11;"ND")+NB.SI(Juillet!F11:AJ11;"ND")+NB.SI(Août!F11:AJ11;"ND")+(NB.SI(Septembre!F11:AJ11;"ND")+NB.SI(Octobre!F11:AJ11;"ND")+(NB.SI(Novembre!F11:AJ11;"ND")+NB.SI(Décembre!F11:AJ11;"ND"))))))

Si ton B4 est vide alors vide maintenant :)

a+
Avatar du membre
Atomiik Loic
Membre habitué
Membre habitué
Messages : 119
Inscrit le : 7 août 2018
Version d'Excel : 2007

Message par Atomiik Loic » 4 septembre 2018, 21:31

Rag02700 a écrit :
4 septembre 2018, 21:06
Hello atomic,

Erreur de syntaxe :

=SI(B4="";"";NB.SI(Janvier!F11:AJ11;"ND")+NB.SI(Février!F11:AJ11;"ND")+(NB.SI(Mars!F11:AJ11;"ND")+NB.SI(Avril!F11:AJ11;"ND")+(NB.SI(Mai!F11:AJ11;"ND")+NB.SI(Juin!F11:AJ11;"ND")+NB.SI(Juillet!F11:AJ11;"ND")+NB.SI(Août!F11:AJ11;"ND")+(NB.SI(Septembre!F11:AJ11;"ND")+NB.SI(Octobre!F11:AJ11;"ND")+(NB.SI(Novembre!F11:AJ11;"ND")+NB.SI(Décembre!F11:AJ11;"ND"))))))

Si ton B4 est vide alors vide maintenant :)

a+
Super , merci beaucoup , ça fonctionne à merveille . :mrgreen:
R
Rag02700
Membre fidèle
Membre fidèle
Messages : 290
Appréciations reçues : 4
Inscrit le : 26 décembre 2017
Version d'Excel : 2010

Message par Rag02700 » 4 septembre 2018, 21:50

Au plaisir :)

Pense à mettre résolu :wink:

A+
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'665
Appréciations reçues : 24
Inscrit le : 14 novembre 2012
Version d'Excel : 2016 FR

Message par R@chid » 5 septembre 2018, 02:16

Re,
R@chid a écrit :
4 septembre 2018, 02:27
Bonsoir @ tous,
en H4 :
=SOMMEPROD(NB.SI(INDIRECT($D$6:$D$17&"!F"&LIGNE(A11)&":AJ"&LIGNE(A11));H$3))
@ tirer vers le bas et vers la droite


@ + +
Personne n'a testé cette belle formule.

Cordialement
2 membres du forum aiment ce message.
"Donnez moi un point d'appui et je soulèverai le monde"
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'698
Appréciations reçues : 646
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 5 septembre 2018, 07:29

Bonjour R@chid,

je viens de tester ta formule sur le fichier du demandeur :
Demande Souhait Congés.xlsx
(108.82 Kio) Téléchargé 2 fois
je confirme que ça marche de façon impeccable !  :appl2:  :appl:  :clap:  :s10:  :ave:

et pas seulement pour ND : pour tous les autres aussi !  :good:  :sp:  :appl2:

remarque : dans le fichier du demandeur, j'ai mis la formule de R@chid  en H4 et je l'ai étirée vers le bas puis à droite, tout comme R@chid  l'avait indiqué ; au début, j'ai cru qu'ça marchait pas car y'avait que des 0 ; mais c'est seulement car le demandeur n'a mis aucun exemple de données sur les feuilles de janvier à décembre ; aussi, j'ai ajouté quelques données sur la feuille janvier et sur la feuille décembre.

dhany
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message