Formule 3 fonctions [Index + Equiv + Max]

Bonjour à tous,

Je cherche une formule ( j'en ai presque trouvé une, mais je n'ai pas été en mesure de l'adapter à mon problème ).

J'ai deux feuilles, sur la feuille1 j'ai en K4 les numéros de dossier et en E4 les emplacements des items

sur la feuille2 j'ai la liste des déplacements des items (qui sont présent dans la feuille1) avec en C3 les numéros de dossier

en G3 les emplacements et en D3 les dates de déplacements des items

J'aimerais que l'emplacement(E4) en feuille1, soit le déplacement du plus récents selon le numéro de dossier inscrit en feuille2

Voici ce que je tente de faire fonctionner...

=INDEX(Feuille2!A3:G10;EQUIV(MAX(Feuille2!D3:D10)*K4;Feuille2!G3:G10;0);7)

Votre aide sera drôlement apprécier

Bonjour Mtek,

Si vos dates de déplacement sont triées en ordre décroissant,

la plus récente en haut, cette formule doit suffire à faire le job

=INDIRECT("Feuille2.G"&EQUIV(K4;$Feuille2.C1:C10;0);1)

Merci njhub de prendre le temps de m'aider,

Malheureusement la liste de la feuille2 risque d'être complété et avec des filtres différent en tout temps

J'ai besoin de trouver l’emplacement le plus récent pour un no.dossier dans la feuille2 sans nécessairement avoir trié une quelconque information.

Bonjour,

un fichier exemple vaut mieux qu'un long discours.

Cordialement

Voici, j'ai crée pour un mini fichier pour l'exemple

Bonjour,

en E5 :

=SIERREUR(INDEX(Feuille2!G$4:G$23;GRANDE.VALEUR(SI(Feuille2!C$4:C$23=$K5;LIGNE(INDIRECT("1:"&LIGNES(Feuille2!C$4:C$23))));1));"")

@ valider par Ctrl+Shift+Enter

@ tirer vers le bas

@ + +

Bonjour R@chid, (merci pour ton aide)

La formule fonctionne en partie, ça ne donne pas le déplacement du No.dossier le plus récent .

J'ai inscrit en milieu de liste le no.dossier M-18080001 avec la date de 2019-08-01 et la formule semble toujours donner le dernier en bas de la liste et non celui avec la date la plus récente

Bonjour l'ami,

je suis désolé je pensais que la base de données est triée par ordre chronologique.

Voir PJ

50mtek-v2.xlsx (11.39 Ko)

Cordialement

Bon matin R@chid,

J'ai transcrit ta formule à mon classeur et ça fonctionne merveilleusement bien.

Merci infiniment, ton aide est apprécié

Rechercher des sujets similaires à "formule fonctions index equiv max"