moyenne par mois

Y compris Power BI, Power Query et toute autre question en lien avec Excel
s
supermarco
Membre habitué
Membre habitué
Messages : 58
Inscrit le : 13 février 2018
Version d'Excel : 2010

Message par supermarco » 4 mars 2018, 20:48

Hello !

Je souhaiterai savoir s'il est possible de faire une fonction qui fasse la moyenne des valeurs pour chaque mois? Par exemple:
1-1-18 : 120
2-1-18 : 115
...
31-1-18 :130
=> moyenne (entre le 1-1 et le 31-1)
puis on recommence pour fevrier.
Merci beaucoup, si besoin je mets un xls.
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'922
Appréciations reçues : 461
Inscrit le : 27 août 2012
Version d'Excel : O365 32 bits

Message par Jean-Eric » 4 mars 2018, 20:56

Bonjour,
Joins un fichier à ta demande. :wink:
Cdlt.
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'361
Appréciations reçues : 237
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 4 mars 2018, 20:59

Bonsoir le forum,
=SOMMEPROD((MOIS($A$2:$A$6)=LIGNE()-1)*($B$2:$B$6))/SOMMEPROD(--(MOIS($A$2:$A$6)=LIGNE()-1))
Moyenne mois.png
Moyenne mois.png (8.46 Kio) Vu 114 fois
s
supermarco
Membre habitué
Membre habitué
Messages : 58
Inscrit le : 13 février 2018
Version d'Excel : 2010

Message par supermarco » 4 mars 2018, 21:20

Merci beaucoup pour vos réponse. Bien sur, ci joint un fichier.


MBBP: Merci pour ce retour interessant mais je vois que les $$ figent le calcul alors que je souhaiterai un format plus general. Est ce possible?
essai 3.xls
(137.5 Kio) Téléchargé 12 fois
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'922
Appréciations reçues : 461
Inscrit le : 27 août 2012
Version d'Excel : O365 32 bits

Message par Jean-Eric » 4 mars 2018, 21:27

Re,
Voir exemple dans fichier joint.
La formule de base (matricielle à valider avec les touches Ctrl + Maj et Entrée) :
{=MOYENNE(SI(MOIS($A$2:$A$6)=MOIS(1&D2);$B$2:$B$6))}
Cdlt.
supermarco.xlsx
(14.22 Kio) Téléchargé 6 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'361
Appréciations reçues : 237
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 4 mars 2018, 21:29

Re,

Tu n'as pas précisé qu'il faut tenir compte du critère année.


E2 :
=SOMMEPROD((MOIS($A$2:$A$252)=LIGNE()-1)*($B$2:$B$252))/SOMMEPROD(--(MOIS($A$2:$A$252)=LIGNE()-1))
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'922
Appréciations reçues : 461
Inscrit le : 27 août 2012
Version d'Excel : O365 32 bits

Message par Jean-Eric » 4 mars 2018, 21:32

Re,
Une nouvelle proposition à étudier.
Cdlt.
essai 3.xlsm
(96.49 Kio) Téléchargé 10 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
s
supermarco
Membre habitué
Membre habitué
Messages : 58
Inscrit le : 13 février 2018
Version d'Excel : 2010

Message par supermarco » 4 mars 2018, 21:41

Jean-Eric a écrit :
4 mars 2018, 21:27
Re,
Voir exemple dans fichier joint.
La formule de base (matricielle à valider avec les touches Ctrl + Maj et Entrée) :
{=MOYENNE(SI(MOIS($A$2:$A$6)=MOIS(1&D2);$B$2:$B$6))}
Cdlt.
supermarco.xlsx
Merci beaucoup. Juste un point stp: si je comprends bien, il faut que j'ai qlq part (comme en COL D) les identifiants des mois pour que ca marche? je dis ca car j'ai pas mal de donnees et je ne pourrai pas mettre SI(...=janvier, ...).?
s
supermarco
Membre habitué
Membre habitué
Messages : 58
Inscrit le : 13 février 2018
Version d'Excel : 2010

Message par supermarco » 4 mars 2018, 21:41

mbbp a écrit :
4 mars 2018, 21:29
Re,

Tu n'as pas précisé qu'il faut tenir compte du critère année.


E2 :
=SOMMEPROD((MOIS($A$2:$A$252)=LIGNE()-1)*($B$2:$B$252))/SOMMEPROD(--(MOIS($A$2:$A$252)=LIGNE()-1))
Alors bien désolé si je n'ai pas été clair en effet.
s
supermarco
Membre habitué
Membre habitué
Messages : 58
Inscrit le : 13 février 2018
Version d'Excel : 2010

Message par supermarco » 4 mars 2018, 21:42

Jean-Eric a écrit :
4 mars 2018, 21:32
Re,
Une nouvelle proposition à étudier.
Cdlt.
essai 3.xlsm
Merci beaucoup. Je prefere le premier car plus facile à magner quand on a plein de données.
Cordialement,
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message