Si (...) sauf si (...) Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
j
jojo789
Membre habitué
Membre habitué
Messages : 64
Inscrit le : 23 septembre 2019
Version d'Excel : 2016

Message par jojo789 » 7 octobre 2019, 17:05

Bonjour

J'utilise cette fonction "SI B2 contient le texte "oui", alors C2=-700"
=SI(NB.SI(B2;"*oui*");"-700";"0")
ça fonctionne.

Mais j'ai besoin de rajouter un "sauf si"
en gros même formule, "sauf si" D2 contient "level 8"


j'ai mis un fichier pour que ce que je dis soit plus clair

merci
si sauf si.xlsx
(10.78 Kio) Téléchargé 5 fois
Avatar du membre
ric
Membre impliqué
Membre impliqué
Messages : 2'446
Appréciations reçues : 206
Inscrit le : 29 mai 2018
Version d'Excel : 365 fr 32 bits

Message par ric » 7 octobre 2019, 17:15

Bonjour,

Un essai ...
=SI(ET(D2<>"level 8";NB.SI(B2;"*oui*"));"-700";"0")





ric
Un bon dépanneur : la touche F8 pour faire un Pas-à-Pas sur le code. :mrgreen:
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'906
Appréciations reçues : 395
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 7 octobre 2019, 17:36

ric a écrit :
7 octobre 2019, 17:15
Bonjour,

Un essai ...
=SI(ET(D2<>"level 8";NB.SI(B2;"*oui*"));"-700";"0")

ric
Bonjour, salut ric,

Les guillemets autour des 2 nombres (-700 et 0) sont inutiles...
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
Avatar du membre
ric
Membre impliqué
Membre impliqué
Messages : 2'446
Appréciations reçues : 206
Inscrit le : 29 mai 2018
Version d'Excel : 365 fr 32 bits

Message par ric » 7 octobre 2019, 19:38

Bonjour à tous,

Je suis bien d'accord Pedro.
Je n'ai que bêtement ajouté la condition demandée. :8_:






ric
Un bon dépanneur : la touche F8 pour faire un Pas-à-Pas sur le code. :mrgreen:
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'710
Appréciations reçues : 248
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 7 octobre 2019, 19:59

bonjour
pour le fun
=(ET(NB.SI(B2;"*oui*")+--(D2="level 8")=2)*-700)+0
cordialement
c'est en cherchant qu'on trouve
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'019
Appréciations reçues : 306
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 7 octobre 2019, 20:48

Bonjour,

Ou encore : =SI(ET(NB.SI(B2;"*oui*");D2<>"level 8");-700;0)
sachant que la seconde condition demandée est :
"sauf si" D2 contient "level 8"
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
j
jojo789
Membre habitué
Membre habitué
Messages : 64
Inscrit le : 23 septembre 2019
Version d'Excel : 2016

Message par jojo789 » 8 octobre 2019, 09:57

merci les experts !
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message