vérifier plusieurs variables et associer la valeur adequate

Y compris Power BI, Power Query et toute autre question en lien avec Excel
w
wox2000
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 12 septembre 2016
Version d'Excel : 2013

Message par wox2000 » 12 septembre 2016, 22:08

Bonsoir ! J'ai créé ce post parce que je n'arrive pas a trouver une solution ni simple,ni rapide ni efficace à mon problème ! AIDEZ-MOI !! SVP =)
Voila le problème : J'ai récemment créer un classeur excel pour étaler les données d'un menu à la semaine à des Feuilles au jour le jour, Midi et Soir. Soit cette fiche ci
Menu.GIF
Menu.GIF (14.27 Kio) Vu 107 fois
et voici le deuxième fichier, celui au service près :
Lundi Midi.GIF
Lundi Midi.GIF (19.22 Kio) Vu 107 fois
et J'aimerais Faire Reconnaitre Ces varaibles ci pour effectuer le calcul correspondant :
Form Menu.GIF
Form Menu.GIF (17.14 Kio) Vu 107 fois


Mon but serait d'organiser mes cellules B20 B22 et B24 du fichier Lundi Midi selon la trame de menu qui peut elle même être établie sous plusieurs formes et il appliquerait les valeurs Effectifs adéquates à cela !
Selon l'effectif renseigné dans mon deuxième fichier ... et la Composition de ce menu ... Excel additionne ou non les effectifs dans Normaux et n'affiche rien dans d'autres cellules si le menu est le même pour tous ... Mon soucis et que je n'ai pas connaissances de toutes les variables pour n'avoir qu'une seule formule (à plusieurs variables dans chacune des cellules correspondantes à Normaux Sans Porc et VG) et ne changer que la trame de menu sur la semaine

J'ai pensé qu'il fallait respecter une equivalence ... du style dans ma cellule "normaux" : =SI(Normaux=SansPorc;SOMME(C9;D9);SI(Normaux=VG;SOMME(C9;E9);SI(((Normaux=SansPorc)=(SansPorc=VG)=(Normaux=VG));SOMME(E9+D9+C9);C9)))
ainsi appliquer chacune des variables aux cellules et le tour est joué ! Non ... Cela n'est pas pris en compte ...

OBJECTIF : Copier-Coller la trame de menu à la semaine et Protéger les Feuilles de calculs des collègues qui manipulent ce dossier toutes les deux heures. Merci à vous ! Je suis ouvert à toutes OPTIONS ... VBA ... Même si je ne programme pas encore, je suis prêt à tenter ! Merci à Vous !
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 11'992
Appréciations reçues : 255
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 12 septembre 2016, 23:23

Bonjour et bienvenue sur le forum

Au lieu d'envoyer des copies d'écran, tu devrais joindre ton fichier.

Bye !
w
wox2000
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 12 septembre 2016
Version d'Excel : 2013

Message par wox2000 » 13 septembre 2016, 00:14

Bonsoir ! Et merci pour ce message ! Je t'ai joint le fichier correspondant ! Merci à toi

PS : Il n'y a que le menu que je ne peux compresser plus ... pour qu'il soit admis sur le forum, merci a toi !
PBExcel2.zip
(22.03 Kio) Téléchargé 9 fois
Pbexcel3.zip
(16.69 Kio) Téléchargé 5 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message