[Résolu] Calcul en fonction de plages horaires Le sujet est résolu

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
A
Aedan
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 18 août 2014
Version d'Excel : 2014 FR

Message par Aedan » 18 août 2014, 18:48

Bonsoir à tous,

J'ai voulu réaliser un tableau afin de faciliter le calcul de mes heures, cependant je suis face à un problème.
Pour que vous compreniez mieux, je pose le contexte :

J'ai un contrat de travail, dans lequel sont précisées des plages horaires (variables selon le jour de la semaine). Je touche une mensualisation, mais toutes les heures travaillées hors des plages horaires prévues dans le contrat doivent être payées en plus de cette mensualisation (logique jusque-là)

Le problème est le suivant, je ne sais pas comment, dans mon tableau, différencier les heures dans le contrat des heures hors contrat.

Je vous joint l'ébauche que j'ai réalisé, même si elle est ridicule :) C'est donc le calcul pour G7 et H7 qui me pose problème.

En espérant avoir été clair,

Merci d'avance de votre aide
Calcul heures.ods
(18.46 Kio) Téléchargé 78 fois
Modifié en dernier par Aedan le 19 août 2014, 23:17, modifié 1 fois.
Q
QuestVba
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 10 juillet 2012
Version d'Excel : 2003

Message par QuestVba » 19 août 2014, 22:00

Un truc comme ceci
=SI(C7<B1;C7-B7;B1-B7)+SI(D7>C1;E7-D7;E7-C1)
A
Aedan
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 18 août 2014
Version d'Excel : 2014 FR

Message par Aedan » 19 août 2014, 23:16

En effet, ça fonctionne parfaitement, merci beaucoup :)

Problème résolu.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message