Formule si, alors... Le sujet est résolu

Forum pour toutes vos questions à propos d'Excel (avec ou sans macros) ...
Bertrand22
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 9 février 2018
Version d'Excel : 2013

Message par Bertrand22 » 24 avril 2018, 11:06

Bonjour,

J'ai bien tenté, avec mes petites connaissances, d'écrire moi même la formule, mais force est de constater que je n'y arrive pas...

Donc je me tourne vers vous.

Il s'agit d'écrire une formule simple qui dit : =SI(C5 compris entre 500 et 1 500 alors B5 égal C5 ; Si C5 inférieur à 500 alors B5 égal 500 ; Si C5 supérieur à 1 500 alors C5 égal 1 500)

Voir également le tableau en pièce jointe pour être plus concret.

Merci d'avance pour vos réponses.
Fichiers joints
Test1.xlsx
(8.59 Kio) Téléchargé 6 fois
Avatar du membre
xorsankukai
Membre fidèle
Membre fidèle
Messages : 486
Appréciations reçues : 19
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 24 avril 2018, 11:17

Bonjour Bertrand22,

A tester :

Code : Tout sélectionner

=SI($C5<500;500;SI($C5>1500;1500;$C5))
test.xlsx
(10.14 Kio) Téléchargé 2 fois
Cordialement,
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 4988
Appréciations reçues : 88
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 24 avril 2018, 13:18

Bonjour le forum

Formule si, alors... sans si :

=MAX((C5<500)*500+(C5>1500)*1500;MIN(C5;1500))
1 membre du forum aime ce message.
Avatar du membre
dhany
Membre impliqué
Membre impliqué
Messages : 2104
Appréciations reçues : 210
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 25 avril 2018, 06:06

Bonjour Bertrand, le forum,

Je te retourne ton fichier modifié :
Test1.xlsx
(9.6 Kio) Téléchargé 3 fois
Regarde la formule en B5 (déjà tirée vers le bas jusqu'en B14).
Merci de me dire si ça te convient.

dhany  Image
Bertrand22
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 9 février 2018
Version d'Excel : 2013

Message par Bertrand22 » 25 avril 2018, 08:33

C'est parfait,

Mais clairement je n'y serais pas arrivé sans votre aide.

Merci

Bertrand
Avatar du membre
dhany
Membre impliqué
Membre impliqué
Messages : 2104
Appréciations reçues : 210
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 25 avril 2018, 08:37

De rien, c'était avec plaisir.  :)

dhany
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 4988
Appréciations reçues : 88
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 25 avril 2018, 09:04

Re,

Pour ta réponse :

Image
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • formule si ... alors ...
    par lolo69490 » 24 février 2015, 15:55 » dans Excel - VBA
    5 Réponses
    526 Vues
    Dernier message par lolo69490
    25 février 2015, 10:17
  • Formule Si Alors Sinon
    par noemie52000 » 16 mars 2017, 16:49 » dans Excel - VBA
    2 Réponses
    703 Vues
    Dernier message par noemie52000
    17 mars 2017, 09:14
  • Formule somme ou =0 alors...
    par tian67 » 25 novembre 2014, 15:56 » dans Excel - VBA
    10 Réponses
    272 Vues
    Dernier message par tian67
    25 novembre 2014, 17:28
  • formule excel SI ALORS
    par trieux » 10 décembre 2013, 08:59 » dans Excel - VBA
    3 Réponses
    311 Vues
    Dernier message par trieux
    10 décembre 2013, 10:04
  • Formule SI suivie de ALORS
    par Fat » 8 septembre 2017, 17:35 » dans Excel - VBA
    6 Réponses
    126 Vues
    Dernier message par Fat
    8 septembre 2017, 22:47
  • Pb de rédaction de la formule SI ALORS SINON
    par MarionMB » 13 mai 2016, 23:16 » dans Excel - VBA
    2 Réponses
    321 Vues
    Dernier message par MarionMB
    14 mai 2016, 14:24