Fonction si & recherche V pour ventilations des TVA en fonction des taux

Y compris Google Docs, Slides et toute autre question en lien avec une application Google
Répondre
p
piresrem
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 16 juillet 2019
Version d'Excel : 2106

Message par piresrem » 23 mai 2020, 15:13

Bonjour a tous,

J'ai récupéré un template sur ce site que j'ai un peu modifié selon mes besoins.

Je facture tous mes clients avec le même taux de TVA, taux normal suisse a 7,7% donc jusqu'ici facile, je prend l'addition des montant facturé au trimestre X0,077 et j'ai la TVA facturé par trimestre.

Mon problème est le suivant pour les notes de frais et les achats je paye 2 taux de TVA différents en a 7,7% et un autre a 2,5%.
Dans la page "journal" pour les notes de frais et dépenses, je rentre le montant HT et le montant de la TVA et la colonne entre les deux calcule le taux appliqué.

Je voudrais pouvoir avoir une ventilation des montants de TVA récupérable 2,5% & 7,7% Par trimestre sur la page "Gestion"

J'ai essayer avec une fonction rechercheV et fonction si mais je ne maitrise pas et je n'arrive a rien, si qqun peux m'aider sa serais top.

https://docs.google.com/spreadsheets/d/ ... sp=sharing
Avatar du membre
Exacel
Membre habitué
Membre habitué
Messages : 100
Appréciations reçues : 6
Inscrit le : 20 février 2020
Version d'Excel : 2019 FR
Version de Calc : *
Version de Sheets : EN/FR

Message par Exacel » 25 mai 2020, 14:04

Bonjour,

Merci pour le partage spontané, ça permet d'intervenir sur le vif.

J'ai travaillé le sujet par une approche par FILTER(), visible et illustrée dans le fichier,
cf. feuille "Gestion Exacel", dans les 8 cases souhaitées,
+ dans la feuille "Journal", des calculs, vérifs, commentaires (non utiles au calcul).

https://docs.google.com/spreadsheets/d/ ... sp=sharing
=SIERREUR(
SOMME(
FILTER(Journal!$G:$G;
  ESTNUM(Journal!$A:$A);
  QUOTIENT(MOIS(Journal!$A:$A)-1;3)+1=CNUM(DROITE($I45;1));
  ARRONDI.AU.MULTIPLE(Journal!$F:$F;1%)=ARRONDI.AU.MULTIPLE(K$44;1%)
)
)
;0)
Particularités :
- Exclusion des lignes sans date
- Sélection par Trimestre (s'il était déjà calculé dans Journal, ce serait plus simple)
- Faire un arrondi à 1% près du Taux de TVA calculé (parce qu'on a 2,49%, 7,68%, 7.76%...)

Dans ce cas, le FILTER() est très adapté, il est plus facilement adaptable, extensible et maintenable que
le QUERY(), sur lequel se basent les autres formules de "Gestion".

A vous de voir...
EMX

:btres:
--
Exacel Solutions
Tools expertise for business
Division of Exaltex
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message