Calcul tableau somme.si.ens

Forum pour toutes vos questions à propos d'Excel (avec ou sans macros) ...
Rodolphej
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 1 février 2018
Version d'Excel : Excel 2016

Message par Rodolphej » 11 octobre 2018, 15:14

Bonjour à tous,

Je souhaite dans le tableau ci-joint :

- En bas, une formule calcul le total des temps pour chaque prénom et je veux :

Si dans la colonne 3 on écrit l'un des 5 prénoms, je veux que le temps se soustraie au total de la personne de la colonne 1 et s'ajoute au total du prénom que l'on écrit dans la colonne 3.

Pour exemple : Si dans la colonne 3, ligne 2, on écrit Loic, le total de rod (B18) devient 44 (56-12) et le total de Loic (B22) devient 163 (151+12)

Merci pour votre aide

Rod
test.xlsx
(9.59 Kio) Téléchargé 5 fois
Avatar du membre
Raja
Passionné d'Excel
Passionné d'Excel
Messages : 5056
Appréciation reçue : 1
Inscrit le : 3 février 2008
Version d'Excel : 2010 à 2016 FR et 2010 EN

Message par Raja » 12 octobre 2018, 11:57

Bonjour,
Formule suivante en B18 et à copier vers le bas :

Code : Tout sélectionner

=SOMMEPROD(((Tableau1[Colonne1]=A18)*(Tableau1[Colonne3]="")+(Tableau1[Colonne3]=A18))*(Tableau1[Colonne2]))
Cdlt,
Raja
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message