Formule SI suivie de ALORS Le sujet est résolu

Forum pour toutes vos questions à propos d'Excel (avec ou sans macros) ...
Fat
Membre habitué
Membre habitué
Messages : 144
Appréciation reçue : 1
Inscrit le : 25 septembre 2015
Version d'Excel : 2010

Message par Fat » 8 septembre 2017, 17:35

Bonjour le Forum,
L'énoncé de ma formule dans la feuille 2 est le suivant :
"Si le texte contenue dans A4 se trouve dans la colonne A de la feuille 1, alors B4 = équivalent de la colonne B, feuille 1"
Mais je n'arrive pas à écrire correctement la formule pour avoir ce résultat.
Je joints un fichier à toute fin utile (en réalité, la liste contient quelques 300 articles !)
Merci pour votre aide
Cordialement Fat
Fichiers joints
Formule SI suivie de ALORS.xlsx
(10.07 Kio) Téléchargé 23 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 5689
Appréciations reçues : 154
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 septembre 2017, 17:45

Bonjour le forum,

Code : Tout sélectionner

=SIERREUR(RECHERCHEV(A4;Feuil1!$A$4:$B$100;2;0);"")
Avatar du membre
Cappe Pierre
Membre impliqué
Membre impliqué
Messages : 1998
Appréciation reçue : 1
Inscrit le : 24 novembre 2012
Version d'Excel : 2010

Message par Cappe Pierre » 8 septembre 2017, 18:05

Bonjour, à tous
une autre version

Code : Tout sélectionner

=SI(A4="C4";A4;"")
Si A4 contient "C4";B4 recevra la valeur de A4

formule à tirer vers le bas dans la colonne B

Amicalement
Pierrot
Pierrot
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 5689
Appréciations reçues : 154
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 septembre 2017, 18:37

Ou :

Code : Tout sélectionner

=SIERREUR(INDEX(Feuil1!B:B;EQUIV(A4;Feuil1!A:A;0));"")
Avatar du membre
Cappe Pierre
Membre impliqué
Membre impliqué
Messages : 1998
Appréciation reçue : 1
Inscrit le : 24 novembre 2012
Version d'Excel : 2010

Message par Cappe Pierre » 8 septembre 2017, 19:04

Salut, mbbp
merci pour cette variante dont je tiens bonne note
Amitiés
Pierrot
Pierrot
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 5689
Appréciations reçues : 154
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 septembre 2017, 19:55

Salut Cappe Pierre,

Toujours content de te croiser lors de discussions.
Fat
Membre habitué
Membre habitué
Messages : 144
Appréciation reçue : 1
Inscrit le : 25 septembre 2015
Version d'Excel : 2010

Message par Fat » 8 septembre 2017, 22:47

Merci Mbbp !
Les 2 formules fonctionnent parfaitement, mais j'ai une préférence pour "l'index".
Grace au Forum, j'ai pu avancer mon travail pour rencontrer peut-être d'autres difficultés en le poursuivant.
Bonne soirée à tous
Cordialement
Fat
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Formule si, alors...
    par Bertrand22 » 24 avril 2018, 11:06 » dans Excel - VBA
    6 Réponses
    118 Vues
    Dernier message par mbbp
    25 avril 2018, 09:04
  • formule si ... alors ...
    par lolo69490 » 24 février 2015, 15:55 » dans Excel - VBA
    5 Réponses
    582 Vues
    Dernier message par lolo69490
    25 février 2015, 10:17
  • Formule Si Alors Sinon
    par noemie52000 » 16 mars 2017, 16:49 » dans Excel - VBA
    2 Réponses
    921 Vues
    Dernier message par noemie52000
    17 mars 2017, 09:14
  • Formule somme ou =0 alors...
    par tian67 » 25 novembre 2014, 15:56 » dans Excel - VBA
    10 Réponses
    336 Vues
    Dernier message par tian67
    25 novembre 2014, 17:28
  • formule excel SI ALORS
    par trieux » 10 décembre 2013, 08:59 » dans Excel - VBA
    3 Réponses
    345 Vues
    Dernier message par trieux
    10 décembre 2013, 10:04
  • Pb de rédaction de la formule SI ALORS SINON
    par MarionMB » 13 mai 2016, 23:16 » dans Excel - VBA
    2 Réponses
    358 Vues
    Dernier message par MarionMB
    14 mai 2016, 14:24