Formule SI suivie de ALORS Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
F
Fat
Membre fidèle
Membre fidèle
Messages : 159
Appréciation reçue : 1
Inscrit le : 25 septembre 2015
Version d'Excel : 2016

Message par Fat » 8 septembre 2017, 17:35

Bonjour le Forum,
L'énoncé de ma formule dans la feuille 2 est le suivant :
"Si le texte contenue dans A4 se trouve dans la colonne A de la feuille 1, alors B4 = équivalent de la colonne B, feuille 1"
Mais je n'arrive pas à écrire correctement la formule pour avoir ce résultat.
Je joints un fichier à toute fin utile (en réalité, la liste contient quelques 300 articles !)
Merci pour votre aide
Cordialement Fat
Formule SI suivie de ALORS.xlsx
(10.07 Kio) Téléchargé 29 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'335
Appréciations reçues : 234
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 septembre 2017, 17:45

Bonjour le forum,
=SIERREUR(RECHERCHEV(A4;Feuil1!$A$4:$B$100;2;0);"")
Avatar du membre
Cappe Pierre
Membre impliqué
Membre impliqué
Messages : 1'997
Appréciations reçues : 7
Inscrit le : 24 novembre 2012
Version d'Excel : 2010

Message par Cappe Pierre » 8 septembre 2017, 18:05

Bonjour, à tous
une autre version

=SI(A4="C4";A4;"")
Si A4 contient "C4";B4 recevra la valeur de A4

formule à tirer vers le bas dans la colonne B

Amicalement
Pierrot
Pierrot
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'335
Appréciations reçues : 234
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 septembre 2017, 18:37

Ou :
=SIERREUR(INDEX(Feuil1!B:B;EQUIV(A4;Feuil1!A:A;0));"")
Avatar du membre
Cappe Pierre
Membre impliqué
Membre impliqué
Messages : 1'997
Appréciations reçues : 7
Inscrit le : 24 novembre 2012
Version d'Excel : 2010

Message par Cappe Pierre » 8 septembre 2017, 19:04

Salut, mbbp
merci pour cette variante dont je tiens bonne note
Amitiés
Pierrot
Pierrot
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'335
Appréciations reçues : 234
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 septembre 2017, 19:55

Salut Cappe Pierre,

Toujours content de te croiser lors de discussions.
F
Fat
Membre fidèle
Membre fidèle
Messages : 159
Appréciation reçue : 1
Inscrit le : 25 septembre 2015
Version d'Excel : 2016

Message par Fat » 8 septembre 2017, 22:47

Merci Mbbp !
Les 2 formules fonctionnent parfaitement, mais j'ai une préférence pour "l'index".
Grace au Forum, j'ai pu avancer mon travail pour rencontrer peut-être d'autres difficultés en le poursuivant.
Bonne soirée à tous
Cordialement
Fat
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message