Recherche de doublons selon deux intervalles de valeurs

Y compris Power BI, Power Query et toute autre question en lien avec Excel
T
Toondek
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 8 août 2017
Version d'Excel : 2016

Message par Toondek » 8 août 2017, 15:38

Bonjour à tous,

Je suis un jeune architecte et je travaille sur AutoCAD pour le dessin des plans.
Dans le cadre de mon travaille, j'ai régulièrement des quantitatifs ou des métrés à faire (mobilier, cloisons, peinture, réseaux, etc ...).
Afin de faciliter les choses, j'ai créé un certains nombres d'objets types (mobilier, cloisons, ...) appelés "blocs" sur AutoCAD et des quels je peux extraire différentes informations directement sur excel (positions, quantités, longueurs, ...).

En récupérant des lignes de code en VBA à droite à gauche, j'ai réussi à automatiser l'extraction de ces informations depuis AutoCAD jusqu'à leurs "organisations" dans excel.
Mais il me reste un dernier point que je n'arrive pas à gérer sous excel : la recherche de doublons

J'ai lu différents sujets sur le net à ce propos mais aucun ne semble correspondre car ma recherches de doublons doit se faire selon deux intervalles.

Je m'explique :

Lors de l'extraction des informations des "blocs" depuis AutoCAD vers Excel, j'exporte notamment leurs positions en X et en Y (Z n'importe pas car il s'agit de plan, donc de 2D).
Je voudrais m'assurer que je n'ai pas 2 blocs qui se superposent et donc faussent mon quantitatifs.
Mon idée était donc de comparer la position en X et en Y de chaque blocs avec celles de tous les autres blocs extrais; plus ou moins un intervalle qui correspondrait à la marge d’erreur (certains blocs pouvant être légèrement décalés mais se superposant assez pour ne pas être détectable à l’œil nue sur AutoCAD).
Si présence de doublons, un message d’erreur dans excel inviterait l'utilisateurs à vérifier le dessin AutoCAD et lignes des blocs correspondant serait mis en rouge pour permettre de retrouver les blocs en questions...

Je ne sais pas si mon explication est très claire... Je joint un fichier exemple si ça peut aider.

Merci en tous cas de m'avoir lu jusque là et merci d'avance pour votre aide.

Cordialement.
Test Quantitatif.xlsx
(13.88 Kio) Téléchargé 20 fois
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'536
Appréciations reçues : 321
Inscrit le : 16 mars 2017
Version d'Excel : 2010

Message par i20100 » 8 août 2017, 16:32

Bonjour,
=SOMMEPROD((B:B=B8)*(G:G=G8)*(H:H=H8))
Toondek-Test Quantitatif (1).xlsx
(14.58 Kio) Téléchargé 11 fois
Vive ces nouvelles saisons qui nous colorent.
isabelle
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'388
Appréciations reçues : 244
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 août 2017, 16:50

Bonjour le forum,

J5 :
=SI(NB.SI($A$5:A5;$A$5:A5)>1;"Doublon";"")
Doublons.png
Doublons.png (9.08 Kio) Vu 182 fois
T
Toondek
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 8 août 2017
Version d'Excel : 2016

Message par Toondek » 8 août 2017, 17:37

Bonjour à vous deux et merci pour vos réponses.

Pourriez-vous m'expilquer un peu vos solutions, mes connaissances en VBA se limitant à du bricolage de code récupérer à gauche à droite, je suis un peu perdu là...

Merci.
p
patrick1957
Passionné d'Excel
Passionné d'Excel
Messages : 3'138
Appréciations reçues : 31
Inscrit le : 24 août 2015
Version d'Excel : 2007-2010-2016 PC

Message par patrick1957 » 8 août 2017, 17:52

Toondek a écrit :Bonjour à vous deux et merci pour vos réponses.

Pourriez-vous m'expilquer un peu vos solutions, mes connaissances en VBA se limitant à du bricolage de code récupérer à gauche à droite, je suis un peu perdu là...

Merci.
Bonjour,

Il n'y a pas de VBA ici dans les formules sommeprod ...
=SOMMEPROD((B:B=B8)*(G:G=G8)*(H:H=H8)) , regarde un peu dans l'aide excel ou sur google :)
Je fais du géocaching et vous ?
Indentez vos codes VBA, ---> http://www.oaltd.co.uk/Indenter/Default.htm
A lire pour les débutants: http://www.xlerateur.com/divers/2010/05 ... nnees-612/
T
Toondek
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 8 août 2017
Version d'Excel : 2016

Message par Toondek » 9 août 2017, 15:38

Bonjour,

Oui pardon, je me suis mal exprimé :D

Je ne l'avais peut-être pas préciser dans mon premier message mais l'idée c'est d'intégrer la recherche de doublons dans une macro.
En faite j'ai déjà paramétré un bouton sur AutoCAD qui lance automatiquement l'extraction des données puis ouvre un fichier excel "gabarit" contenant une macro qui récupéré les infos et les ranges, les filtres, etc, ...
Je voudrais que cette recherche de doublons puisse se lancer directement de la macro de mon fichier gabarit.

Sinon pour la fonction "SOMMEPROD", je me suis renseigné et j'ai fait quelques testes avec.
Effectivement ça semble pas mal mais je ne vois pas à quel moment on peut intégrer une marge d’erreur?

Merci.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message