Formules Matricielles 3D

Bonjour,

Je souhaite modifier cette formule pour que la somme se fasse sur la cellule B13 et B47. En l'état la formule fonctione mais uniquement sur la formule B13 :

=SOMMEPROD(SOMME.SI(INDIRECT(NomsFeuilles&"!A6");D5;INDIRECT(NomsFeuilles&"!B13")))

J'ai tenté cette formule mais sans succès

=SOMMEPROD(SOMME.SI(INDIRECT(NomsFeuilles&"!A6");D5;INDIRECT(NomsFeuilles&"!B13;B47")))

Merci

bonjour

c'est du coté de ton "A6" que ça cloche car ce n'est qu'une cellule ;mais peut etre que tu n'as pas besoin de ça

met un bout de fichier ou une maquette en en piecejointe

cordialement

tulipe_4 a écrit :

bonjour

c'est du coté de ton "A6" que ça cloche car ce n'est qu'une cellule ;mais peut être que tu n'as pas besoin de ça

met un bout de fichier ou une maquette en en pièce jointe

cordialement

Voici un petit exemple

Dans cette exemple dans l'onglet Cumul, la Cellule B6 doit afficher "170" qui est la somme des cellules B6, B20 quand A1 et A15 corresponde à "Ep"

Merci

4test.zip (10.48 Ko)

Bonsoir,

Est-ce ça te va comme solution ? J'ai utilisé simplement la formule 3D car le résumé à la même disposition que les sources.

0copie-test.zip (11.86 Ko)

Pas réellement car en B20 sur la feuille 1.02 il s'agit de Ep et non de Dg donc en "30" on devrait avoir Ep : 170 et dg : 20

Est-ce que ce type de formule peut être la solution :

=SOMMEPROD((T(INDIRECT("'Feuil"&{1.2.3.4}&"'!a2"))="x")*(T(INDIRECT("'Feuil"&{1.2.3.4}&"'!b2"))="x")*N(INDIRECT("'Feuil"&{1.2.3.4}&"'!c2")))

bonjour

un essai

du 3d en formule ce n'est pas toujours commode

7doudel.xlsx (16.29 Ko)

cordialement

tulipe_4 a écrit :

bonjour

un essai

du 3d en formule ce n'est pas toujours commode

cordialement

Merci

Ça semble fonctionner, je vais tenter de comprendre, je pense que j'ai du travail avant de tout saisir et de l'appliquer à une feuille plus complexe

re

pour fonctionner pas de soucis

astuce pour completer DATA

1) tu selectionnes la cel a remplir

2) tu saisis = et tu vas sur la feuille puis tu selectionnes la plage

3) tu effaces le = et les '

facile et sans erreur (avis d'un specialiste de )

si tu a autre chose que dp ou ep

tu rajoute dans la plage liste et tu modifie la partie CHOISIR d'autant

POur les amateurs noter que INDIRECT fonctionne avec CHOISIR car pas avec d'autres moyens de selectionner une val "texte"

cordialement

A chaque fois que je crée un onglet il faut que je saisisse les zone à la main ?

re

oui monsieur ;et pour les plages ep et dp comme je l'ai fait dans data ;tu comprends que excel ne peux pas deviner ou chercher

cordialement

doudel77 a écrit :

A chaque fois que je crée un onglet il faut que je saisisse les zone à la main ?

Re, Salut tulipe_4,

Malgré la non réponse à ma proposition, voilà une précision concernant les formules 3D. Dans les formules 3D, les 2 bornes (début et fin) sont fixés. Il suffit de créer un onglet de la même structure entre les 2 bornes, la formule 3D marchera.

Ok bon je vais faire comme ça, mais bon peut être qu'une petite macro viendrait à mon secours. Ce n'est pas trop pour la charge de travail, c'est plus pour limiter les manipulations et donc les erreurs.


Raja a écrit :
doudel77 a écrit :

A chaque fois que je crée un onglet il faut que je saisisse les zone à la main ?

Re, Salut tulipe_4,

Malgré la non réponse à ma proposition, voilà une précision concernant les formules 3D. Dans les formules 3D, les 2 bornes (début et fin) sont fixés. Il suffit de créer un onglet de la même structure entre les 2 bornes, la formule 3D marchera.

Tu peux préciser

Re,

Prends le fichier joint dans mon message précédent, copie l'onglet 1.01 et insère le entre l'onglet 1.01 et 1.02 et teste le résultat.

Raja a écrit :

Re,

Prends le fichier joint dans mon message précédent, copie l'onglet 1.01 et insère le entre l'onglet 1.01 et 1.02 et teste le résultat.

Désolé Raja, a pas compris

Re,

Bon on recommence. As-tu récupéré le fichier "Copie Test.xls" que j'ai joint dans mon ancien post ?

Raja a écrit :

Re,

Bon on recommence. As-tu récupéré le fichier "Copie Test.xls" que j'ai joint dans mon ancien post ?

Oui je l'ai

Re,

Regarde dans l'onglet "Cumul" si le résultat est ce que tu attendais avoir. Si la réponse est oui, insère un onglet entre 1.01 et 1.02 et tu constateras que la formule 3D marche toujours.

Raja a écrit :

Re,

Regarde dans l'onglet "Cumul" si le résultat est ce que tu attendais avoir. Si la réponse est oui, insère un onglet entre 1.01 et 1.02 et tu constateras que la formule 3D marche toujours.

Il me manque des données, la difficulté c'est que les "ep" ne sont pas placés systématiquement au même endroit et dans dans ton exemple il me manque des données car les "ep" situés dans le deuxième tableau de l'onglet 1.02 sont pris en compte dans les "dp".

bonjour

c'etait a prevoir ;donc pour pouvoir faire ta somme 3D etant donné que tes données sont en desordre ; tu es obligé de "preselectionner" dans Data ; de maniere à recupérer "ou?" et "quoi?"

meme avec du vba ;il me parait difficile d'automatiser car les plages ep et dp ne sont (seront pas fixes) ; a moins de localiser chaque ep ou dp dans chaque feuille et de chercher dans une plage definie avec un "offset" =>dictionnaire ; pourquoi pas ?

cordialement

doudel77 a écrit :

la difficulté c'est que les "ep" ne sont pas placés systématiquement au même endroit.

Re,

Dans ce cas tu devrais abandonner les formules 3D. Ce n'est pas ce qu'il te faut dans ce cas de figure. Car en général, l'idée des formules 3D (ligne, colonne,onglet), les données se trouvent aux mêmes endroits dans différents onglets. Il faut surement passer par la programmation. Mois, je passe la main. Peut être quelqu'un viendra à ton secours.

Rechercher des sujets similaires à "formules matricielles"