extraction de 2 chiffres dans une suite de chiffres Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
c
clepolux
Jeune membre
Jeune membre
Messages : 37
Inscrit le : 12 mai 2016
Version d'Excel : 2016

Message par clepolux » 28 juin 2017, 14:04

Bonjour,

je cherche à extraire l'année dans un numéro de sécurité sociale, saisi dans une seule cellule.

J'ai ça : 2920737354258

je cherche ça 92 ou 1992.

Merci à vous, si vous avez une idée, parce que la je sèche.

Bonne journée
Avatar du membre
Raja
Passionné d'Excel
Passionné d'Excel
Messages : 5'063
Appréciation reçue : 1
Inscrit le : 3 février 2008
Version d'Excel : 2010 à 2016 FR et 2010 EN

Message par Raja » 28 juin 2017, 14:12

Bonjour,
Essaye comme ça :
=STXT(NUMSS;2;2)
Modifié en dernier par Raja le 28 juin 2017, 14:50, modifié 2 fois.
Cdlt,
Raja
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'105
Appréciations reçues : 165
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 28 juin 2017, 14:25

bonjour
pour le fun
=SI(STXT(C3;2;2)*1+2000>ANNEE(AUJOURDHUI());STXT(C3;2;2)*1+1900;STXT(C3;2;2)*1+2000)
cordialement
c'est en cherchant qu'on trouve
c
clepolux
Jeune membre
Jeune membre
Messages : 37
Inscrit le : 12 mai 2016
Version d'Excel : 2016

Message par clepolux » 28 juin 2017, 14:42

Merci Raja ça fonctionne très bien je ne la connaissait pas celle-ci. Et merci tulipe_4 ça complète très bien.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 28 juin 2017, 14:46

Bonjour le forum,

Et longue vie aux centenaires !
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'105
Appréciations reçues : 165
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 28 juin 2017, 15:28

salut mbbp
faut savoir anticiper l'allongement de la durée de vie :lol: :lol:
cordialement
c'est en cherchant qu'on trouve
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message