Extraction de données

Y compris Power BI, Power Query et toute autre question en lien avec Excel
b
balby64
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 26 avril 2017
Version d'Excel : 2016 FR

Message par balby64 » 26 avril 2017, 22:53

Bonjour a tous,
J'ai un soucis, je n'arrive pas a le régler !
Donc mon tableau que voici en pièce jointe :
Pointage.xlsx
(9.95 Kio) Téléchargé 8 fois
je voudrais extraire dans le recap sur la partie de droite le numéro d'ordre de travail et en face toutes les imputations d'heures qui lui sont attribué.
Je veux qu'a chaque fois qu'il y ai un numero d'ordre de travail dans mon tableau, celui ci (s'il est nouveau) soit recopié sur la droite dans la partie recap avec toutes les heures qui lui sont attribué.
Est ce possible ? Sa me parait bien compliqué ^^
Merci a celui qui y arrivera !
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'716
Appréciations reçues : 333
Inscrit le : 16 mars 2017
Version d'Excel : 2010

Message par i20100 » 26 avril 2017, 23:13

Bonjour,

insérer la formule suivante en cellule J6 et recopier vers le bas
=SOMMEPROD(($D$2:$D$60000=I6)*($E$2:$E$60000))
Vive ces nouvelles saisons qui nous colorent.
isabelle
b
balby64
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 26 avril 2017
Version d'Excel : 2016 FR

Message par balby64 » 26 avril 2017, 23:47

Merci bien sa me permet de calculer les heures, mais il faut que je rentre manuellement les numéro d'ordre de travail en face, comment les recopié eux aussi automatiquement, mais bien sur en un seul exemplaire, histoire d'avoir le numero d'ordre et les le total des heures attribué, est ce clair ?
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'716
Appréciations reçues : 333
Inscrit le : 16 mars 2017
Version d'Excel : 2010

Message par i20100 » 27 avril 2017, 00:41

un tableau croisé dynamique serait une bonne solution,
j'ai nommé la plage source dynamiquement au nom de : plg avec la formule suivante
=DECALER(Feuil1!$A$1;0;0;NBVAL(Feuil1!$A:$A);NBVAL(Feuil1!$1:$1))
balby64-Pointage.xlsm
(20.84 Kio) Téléchargé 4 fois
Vive ces nouvelles saisons qui nous colorent.
isabelle
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Extraction de données
    par tifan » 25 mars 2016, 11:50 » dans Excel - VBA
    12 Réponses
    333 Vues
    Dernier message par tifan
    29 mars 2016, 13:35
  • extraction de données
    par impreza73 » 26 août 2014, 17:30 » dans Excel - VBA
    3 Réponses
    334 Vues
    Dernier message par impreza73
    27 août 2014, 22:17
  • Extraction de données
    par fredolilo » 13 octobre 2016, 18:20 » dans Excel - VBA
    5 Réponses
    152 Vues
    Dernier message par fredolilo
    14 octobre 2016, 09:13
  • Extraction de données
    par Delgusto » 28 février 2019, 17:00 » dans Excel - VBA
    25 Réponses
    410 Vues
    Dernier message par Delgusto
    3 mars 2019, 15:57
  • Extraction de Données
    par KTM » 18 mars 2020, 14:26 » dans Excel - VBA
    4 Réponses
    89 Vues
    Dernier message par KTM
    18 mars 2020, 22:24
  • extraction de données
    par nickal » 18 janvier 2018, 10:38 » dans Excel - VBA
    2 Réponses
    110 Vues
    Dernier message par nickal
    18 janvier 2018, 11:08