Fonction Si, cherche et stxt Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
n
nanouraso
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 13 avril 2017
Version d'Excel : 2013

Message par nanouraso » 13 avril 2017, 13:42

Bonjour,

Je souhaite insérer une formule dans une BDD qui me permette de trouver des caractères d'une chaîne en fonction de sa structure.

En effet, dans la BDD nous avons 3 formes d'imputation :
- R10SR-TM04
- RP10GP-ACO-E-C-10
- VP10TER-T00-AFG-1790

En fonction de l'imputation, je souhaite voir apparaitre les 3 caractères surlignés dans une colonne, ou s'il s'agit du 1er modèle d'imputation de reprendre les données dans une autre colonne.

J'ai utilisé la formule ci-dessous qui ne fonctionne pas :
=SI(CHERCHE("rp";N11);STXT(N11;8;3);SI(CHERCHE("vp";N11);STXT(N11;13;3);AA11)).

Pour le 1er et 3ème modèle j'ai l'erreur #valeur mais ça fonctionne avec le 2ème modèle d'imputation.

J'ai joint un fichier exemple. Quelqu'un saurait-il m'aider ?

Merci le forum
Help.xlsx
(54.48 Kio) Téléchargé 27 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'447
Appréciations reçues : 428
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 13 avril 2017, 13:53

bonjour,

=SI(GAUCHE(N2;2)="RP";STXT(N2;8;3);SI(GAUCHE(N2;2)="VP";STXT(N2;13;3);AA2))
n
nanouraso
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 13 avril 2017
Version d'Excel : 2013

Message par nanouraso » 13 avril 2017, 14:10

merci h2so4 :D

en lisant ta formule je me sens bête :?
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message