Fonction Si, cherche et stxt

Bonjour,

Je souhaite insérer une formule dans une BDD qui me permette de trouver des caractères d'une chaîne en fonction de sa structure.

En effet, dans la BDD nous avons 3 formes d'imputation :

  • R10SR-TM04
  • RP10GP-ACO-E-C-10
  • VP10TER-T00-AFG-1790

En fonction de l'imputation, je souhaite voir apparaitre les 3 caractères surlignés dans une colonne, ou s'il s'agit du 1er modèle d'imputation de reprendre les données dans une autre colonne.

J'ai utilisé la formule ci-dessous qui ne fonctionne pas :

=SI(CHERCHE("rp";N11);STXT(N11;8;3);SI(CHERCHE("vp";N11);STXT(N11;13;3);AA11)).

Pour le 1er et 3ème modèle j'ai l'erreur #valeur mais ça fonctionne avec le 2ème modèle d'imputation.

J'ai joint un fichier exemple. Quelqu'un saurait-il m'aider ?

Merci le forum

28help.xlsx (54.48 Ko)

bonjour,

=SI(GAUCHE(N2;2)="RP";STXT(N2;8;3);SI(GAUCHE(N2;2)="VP";STXT(N2;13;3);AA2))

merci h2so4

en lisant ta formule je me sens bête

Rechercher des sujets similaires à "fonction cherche stxt"