Mois.decaler à choix multiples Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
C
Corolian
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 11 mars 2017
Version d'Excel : 2007 et 2013

Message par Corolian » 11 mars 2017, 16:00

Bonjour
Et merci à celles et ceux qui prennent du temps pour aider les autres et prodiguent de bons conseils.
Voici mon problème ; à partir du fichier joint ;
En prenant en compte la colonne P, Date Origine fin contrat ;
En considérant en colonne T ; Oui/Non d’une tacite reconduction du contrat ; valeur en mois ; en colonne U
Je recalcule la nouvelle date de fin de contrat, en colonne W

Je ne réussis pas à faire de formule mois.decaler si ; en cumulant les conditions ci-dessous

je voudrai prendre en compte la valeur O (oui) ; N (non) ou si cellule vide en colonne T, afin de
Soit calculer la nouvelle date selon la durée de reconduction et si en cellule colonne T = O
Soit reporter la date de fin de contrat d’origine (colonne P) en cellule colonne W si en cellule colonne T = N
Ou reporter la date de fin de contrat d’origine (colonne P) en cellule colonne W si en cellule colonne T = vide
Et reporter en onglet Renouvellement, ligne à ligne les clients et leur chiffre d’affaires qui ont en colonne R ; Nbre mois au renouvel. ; un nombre de mois compris entre 1 et 4.

J’espère être clair dans mon descriptif
Par avance merci de votre aide
TOP clients vers_b.xlsx
(47.81 Kio) Téléchargé 12 fois
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 1'555
Appréciations reçues : 88
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 11 mars 2017, 18:06

Bonsoir Corolian et bienvenue à toi,

Je ne sais pas trop si j'ai compris :scritch:

En W15, essaie:
=SI(P15=0;"";SI(T15="O";MOIS.DECALER(P15;U15);P15))
En feuille Renouvellement (où tu veux):
=SIERREUR(INDEX('015_MONTPELLIER'!$[surligner]C[/surligner]$15:$[surligner]C[/surligner]$80;PETITE.VALEUR(SI(('015_MONTPELLIER'!$R$15:$R$80>0)*('015_MONTPELLIER'!$R$15:$R$80<4);LIGNE('015_MONTPELLIER'!$R$15:$R$80)-14);LIGNES($1:4)));"")
Valider avec Ctrl+Shift+Enter, puis recopier en bas. Même formule pour les CA avec des 'F' au lieu des 'C' surlignés
C
Corolian
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 11 mars 2017
Version d'Excel : 2007 et 2013

Message par Corolian » 11 mars 2017, 19:16

Merci des réponses
en W15 la formule fonctionne, même si la première fois le système m'indique fonction circulaire.
Super grand merci.

concernant la deuxième ça ne marche pas et ne m'affiche aucun code erreur.
Au cas ou, un petit coup de pouce supplémentaire sans abuser.

Par avance merci
Corolian
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 1'555
Appréciations reçues : 88
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 11 mars 2017, 20:46

Je ne vois rien qui expliquerait la présence d'une référence circulaire en W15?
La seconde proposition fonctionne chez moi ... ton fichier en pièce jointe, avec les deux solutions proposées:
TOP clients vers_b (Corolian).xlsx
(46.99 Kio) Téléchargé 8 fois
C
Corolian
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 11 mars 2017
Version d'Excel : 2007 et 2013

Message par Corolian » 11 mars 2017, 22:24

Bonjour
Sans abuser un dimanche
J'applique la formule suivante
=SIERREUR(INDEX('015_MONTPELLIER'!$C$15:$C$80;PETITE.VALEUR(SI(('015_MONTPELLIER'!$R$15:$R$80>0)*('015_MONTPELLIER'!$R$15:$R$80<4);LIGNE('015_MONTPELLIER'!$R$15:$R$80)-14);LIGNES($1:4)));"")

ça fonctionne si j'applique cette formule sur l'onglet 015_MONTPELLIER du fichier test
mais si je veux appliquer cette formule à un nouvel onglet 061_MARTIGUES, en remplaçant 015_MONTPELLIER par 061_MARTIGUES
en tapant CTRL+MAJ+ENTER
Rien ou après plusieurs essais, le résultat ne reprend pas la première valeur correspondante à >0 et <4.

je coince et +, je dois finaliser le fichier pour demain. je ne sais quoi faire

Par avance merci
TOP clients vers_c.xls
(150 Kio) Téléchargé 11 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message