Index et Equiv

Bonsoir,

Ci-joint un classeur, je souhaite trouver une valeur dans un tableau ayant plusieurs paramètres, je ne sais pas comment m'y prendre.

Merci d'avance

Cordialement,

Philippe

14indexetequiv.xlsx (10.22 Ko)

Bonsoir,

Avec un classeur corrigé (les chiffres sont au bon format (pas en texte pour certain)

et la Valeur 2 est inutile, puisque c'est la même ligne que la Valeur 1

17indexetequiv.xlsx (10.71 Ko)

Bonsoir à tous,

Une formule en F18 :

=RECHERCHEV(F13;A5:L9;1+EQUIV(F15;C3:L3;0)+EQUIV(F16;DECALER(B4;;EQUIV(F15;C3:L3;0);;5);0);FAUX)

Merci beaucoup à vous deux,

Bonne soirée,

Philippe

bonsoir

un essai partiellement automatisé

21phillipe-02.xlsx (11.53 Ko)

cordialement

Merci Tulipe4

Bonne soirée,

Philippe

Bonsoir à tous,

Je me suis complétement planté, je me suis mal expliqué, je vous joint un nouveau classeur pour vous expliquer.

Encore merci pour votre aide.

Philippe

14index.xlsx (13.58 Ko)

bonjour

un essai

1) je cherche les valeurs proches ; en fonction de la tranche (valeur 1)

2) sommeprod utilise ces 2 valeurs (qui sont fatalement en colonne b et C

ton tablo est un beau bordel , des valeurs ne sont pas numeriques je 'lai corrigé (trop bon)

20phil002.xlsx (14.39 Ko)

cordialement

Bonsoir Tulipe_4,

Oui en effet, c'est un vrai bordel, en fait je l'ai scanné avec un logiciel OCR qui le renvoi dans Excel, ne sais pas s’il existe une option pour que les chiffres soient reconnus comme tels.

Sinon encore un grand merci pour le fichier corrigé et l'exemple.

Je fais des essais et je te confirme que ça va.

Bonne soirée

Philippe

ABBYY FineReader 12

Sous le chiffre 20 de la zone B

ça ne fonctionne pas, Excel renvoi toujours 0,00

Pour le reste ça va très bien.

Merci

Philippe


C'est bon j'ai trouvé, j'ai retapé "20" et ça va, sûrement encore un problème de texte.

Encore merci,

Bonne soirée

Philippe

bonjour

moi aussi j'en ai retapé un bon paquet ; mais probablement oublié ou loupé

citation du jour

A la guerre ,tout le monde n'est pas tué

la preuve ...

cordialement

Rechercher des sujets similaires à "index equiv"