Référence à un "nom" différent en fonction d'une case choix Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
G
GillesBouchard81
Jeune membre
Jeune membre
Messages : 19
Inscrit le : 27 décembre 2012
Version d'Excel : 2010

Message par GillesBouchard81 » 7 février 2017, 22:04

Bonjour,

J'ai fait une formule somme.si, où la plage_somme fait référence à une plaque à laquelle j'ai donné un "nom" (définir un nom)
J'ai donc les plages X Y Z qui portent leur nom et j'aimerais que ma formule somme.si change en fonction du chois de la plage défini avec une case avec liste déroulante.

J'ai joint un fichier pour que ça soit plus claire, désolé de ne pas arriver à mieux vulgariser mon problème! :shock: :shock: :shock:

En résumé, j'aimerais que les cases G4, G5 et G6 fassent la somme.si en fonction du choix de plage défini par la case G2.

Est-ce possible?

Merci de votre précieuse aide!!

Gilles Bouchard
Classeur3.xlsx
(9.11 Kio) Téléchargé 10 fois
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 1'634
Appréciations reçues : 95
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 7 février 2017, 22:25

Bonsoir,

Un petit avant d'aller dormir :wink:
=SOMME.SI($A$4:$A$9;F4;INDIRECT($G$2))
... Si j'ai compris!?
G
GillesBouchard81
Jeune membre
Jeune membre
Messages : 19
Inscrit le : 27 décembre 2012
Version d'Excel : 2010

Message par GillesBouchard81 » 7 février 2017, 22:32

Fantastique, je ne connaissais pas la fonction INDIRECT!!!

C'est en plein dans le mile.

Merci beaucoup!!
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message