Numérotation auto avec critères

Bonjour,

Je me tourne vers vous pour cause de blocage.

J'ai un BPU avec des titres, des sous-titres et des actions.

Les titres sont numéroté 1, 2, ..., 10, 11; Les sous-titres de même.

Les actions sont incrémentés depuis le 1 en suivant.

Lorsque j’insère des lignes, renuméroter les titres et sous-titres ne me prend pas trop de temps mais renuméroter toutes les actions bonjours.

Avez-vous une solution.

En pj un exemple de ligne ajoutée dans un fichier de 500 lignes (en jaune).

Ivan

11numerotation.xlsx (12.45 Ko)

Bonjour,

Il est possible d'utiliser une formule du type

=SI(ET(A3="";B3="");MAX($C2:C$3)+1;"")

à saisir en C3

Merci ouisansdoute

c'est génial... cà marche nickel

Bonjour à tous.

Je ré-ouvre le sujet car après des années de bon fonctionnement, mon service des marchés me demande de modifier mon fichier BPU.

J'ai repris l'extrait de fichier initial avec la formule que ouisansdoute m'avait trouvée et j'y ai insérer un onglet avec la présentation numérologique que le SM souhaite (incrémentation différente en colonne C).

L'idée c'est que lorsque l'on ajoute des lignes de prestations, la numérotation puisse s'adapter facilement.

Oups, je me suis trompé de fichier test.

Voici le bon en pj

Je vous prie de bien vouloir m'excuser.

Ivan

Bonjour,

Une formule à tester en C3 :

=SI(ET(A3="";B3="");SI(C2="";1;C2+1);"")

A recopier vers le bas.

Bonjour ouisansdoute,

Désolé de répondre si tardivement mais vacances en famille oblige.

Merci pour ta solution, cela marche parfaitement.

Je passe le post en résolut.

Merci encore.

Rechercher des sujets similaires à "numerotation auto criteres"