Moyenne de certaines cellules en excluant les 0

Y compris Power BI, Power Query et toute autre question en lien avec Excel
e
edouard41
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 30 novembre 2016
Version d'Excel : 2007

Message par edouard41 » 30 novembre 2016, 20:24

Bonjour à tous,

Je souhaite calculer une moyenne en excluant les 0. Par contre, je ne veux pas calculer la moyenne de toutes les cellules dans une plage (ex: A1:A10), mais plutôt certaines cellules seulement (ex: A1, A4, A7). Je ne trouve pas comment faire ça avec la fonction moyenne.si ou un combinaison de fonctions (moyenne(si(...)). Sauriez-vous comment faire?

Merci
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'201
Appréciations reçues : 444
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 30 novembre 2016, 22:06

Bonsoir,

En B1:B10, tu mets 1 en regard des cellules que tu inclues dans ta moyenne, et :
=MOYENNE.SI.ENS(A1:A10;A1:A10;"<>0";B1:B10;1)
Cordialement.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 30 novembre 2016, 23:11

Bonsoir le forum,
=SOMME(A1;A4;A7;)/NB.SI(A1:A10;">"&0)
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 30 novembre 2016, 23:48

Ou : formule matricielle :
Moyenne.png
Moyenne.png (7.17 Kio) Vu 235 fois
m
mdo100
Membre dévoué
Membre dévoué
Messages : 806
Appréciations reçues : 34
Inscrit le : 25 mai 2013
Version d'Excel : 2010 FR

Message par mdo100 » 1 décembre 2016, 02:07

Bonsoir à toutes et tous,

Une contribution.
=ARRONDI(SOMME(A1:A10)/NB.SI(A1:A10;">0");2)
Cordialement
e
edouard41
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 30 novembre 2016
Version d'Excel : 2007

Message par edouard41 » 1 décembre 2016, 15:28

Résolu. MERCI!!
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message