selectionner uniquement les textes en majuscule Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
P
PhilippeQuébec
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 7 juin 2015
Version d'Excel : 2010

Message par PhilippeQuébec » 18 novembre 2016, 23:33

Bonjour à tous,

J'ai un très gros fichier sur une seule colonne, mais plus de 8000 lignes!
Mon objectif est de sélectionner uniquement les noms des entreprises et ceux-ci sont les seuls en majuscule.
Mais comment faire ?
J'ai pensé mettre les cases en couleur puis faire faire un tri par couleur pour les sélectionner.

Merci de votre aide.

Philippe
Avatar du membre
bernard22
Membre dévoué
Membre dévoué
Messages : 882
Appréciations reçues : 11
Inscrit le : 26 mars 2015
Version d'Excel : 2013FR

Message par bernard22 » 19 novembre 2016, 08:36

Bonjour,
Test "Majuscule" du premier caractère :

En colonne B, essaie

=SI(ET(CODE(GAUCHE(A2;1))<91;CODE(GAUCHE(A2;1))>66);"Majuscule";"")
Puis, Filtrer la colonne B

Avec un fichier, il est plus facile de répondre précisement

@+
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'135
Appréciations reçues : 349
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 19 novembre 2016, 13:06

Bonjour,

met 1 si tout le texte est en majuscule :
=SIERREUR(TROUVE(MAJUSCULE(A2);A2);0)
eric
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
P
PhilippeQuébec
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 7 juin 2015
Version d'Excel : 2010

Message par PhilippeQuébec » 20 novembre 2016, 17:22

Merci beaucoup à vous deux.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message