casse tête Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
c
chtimili
Membre habitué
Membre habitué
Messages : 141
Inscrit le : 3 janvier 2015
Version d'Excel : 2010

Message par chtimili » 8 novembre 2016, 09:01

bonjour a tous


j'ai en colonne D un stock départ:
si je saisie en B une sortie de stock mon stock final Diminue en A:c'est ok
si je saisie en C une entrée de stock mon stock final augmente en A:c'est ok



j'ai un bouton raz qui supprime les données colonne B et C et j'aimerai bien qu'a ce moment la aussi les valeurs du stock final deviennent les valeurs du stock départ

hé bin c'est un casse tête
test stock.xlsm
(22.35 Kio) Téléchargé 11 fois
p
patrick1957
Passionné d'Excel
Passionné d'Excel
Messages : 3'122
Appréciations reçues : 32
Inscrit le : 24 août 2015
Version d'Excel : 2007-2010-2016 PC

Message par patrick1957 » 8 novembre 2016, 09:15

Bonjour,

pas spécialiste des gestions d'articles , mais tu ne comptes pas mettre une date d'entrée et une à la sortie ???
Ça me parait élémentaire non ?

P.
Je fais du géocaching et vous ?
Indentez vos codes VBA, ---> http://www.oaltd.co.uk/Indenter/Default.htm
A lire pour les débutants: http://www.xlerateur.com/divers/2010/05 ... nnees-612/
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 novembre 2016, 09:23

Bonjour le forum,

Voir le fichier joint.
STOCKS données et cumuls.xlsm
(15.46 Kio) Téléchargé 11 fois
c
chtimili
Membre habitué
Membre habitué
Messages : 141
Inscrit le : 3 janvier 2015
Version d'Excel : 2010

Message par chtimili » 8 novembre 2016, 09:24

salut Patrick

oui tu as raison . je suis au début du projet et souhaiter régler ce problème . je ne connais pas encore le tableau final .
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 446
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 8 novembre 2016, 09:37

Bonjour,
Sub Exemple_RAZ()
    Dim n%
    With ActiveSheet
        n = Range("D" & .Rows.Count).End(xlUp).Row
        .Range("D2:D" & n).Value = .Range("A2:A" & n).Value
        .Range("B2:C" & n).ClearContents
    End With
End Sub
Formule :
Soit tu mets : =D2+C2-B2
Soit : =SOMME(D2;C2;-B2) ou =SOMME(C2:D2;-B2)
Ou même : SOMME(C2:D2)-B2
Mais ta formule actuelle est un mélange des genres douteux.

Cordialement.
c
chtimili
Membre habitué
Membre habitué
Messages : 141
Inscrit le : 3 janvier 2015
Version d'Excel : 2010

Message par chtimili » 8 novembre 2016, 10:41

Merci a vous
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Casse Tête
    par squallor72 » 4 août 2015, 12:07 » dans Excel - VBA
    3 Réponses
    340 Vues
    Dernier message par squallor72
    13 août 2015, 14:17
  • Casse-tête
    par ctrl-alt-del » 28 juin 2014, 20:37 » dans Excel - VBA
    5 Réponses
    508 Vues
    Dernier message par tulipe_4
    7 juillet 2014, 21:08
  • help casse tête ;)
    par kumade44 » 7 février 2019, 06:30 » dans Excel - VBA
    15 Réponses
    772 Vues
    Dernier message par kumade44
    8 février 2019, 13:33
  • Casse tête
    par cemoibob » 6 septembre 2019, 12:21 » dans Excel - VBA
    3 Réponses
    118 Vues
    Dernier message par cemoibob
    7 septembre 2019, 18:19
  • Planning - casse tête
    par Babou193 » 19 octobre 2019, 12:13 » dans Excel - VBA
    2 Réponses
    126 Vues
    Dernier message par Babou193
    20 octobre 2019, 17:35
  • casse tête : taux d'impot
    par Sassi » 15 décembre 2018, 13:34 » dans Excel - VBA
    6 Réponses
    177 Vues
    Dernier message par Sassi
    15 décembre 2018, 17:00