Simuler un CTRL V sur Command_click Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
M12
Passionné d'Excel
Passionné d'Excel
Messages : 3'118
Appréciations reçues : 120
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 2 octobre 2016, 10:20

Bonjour à tous,
Dans la cadre d'un club informatique, j'ai élaborer un USF pour reproduire les formules EXCEL de la cellule active afin de les mettre en zoom.

Si je copie/colle par les touches la formule pas de soucis, mais j'aurais voulu le faire par un command bouton, qui me copierais ma formule et la placerais dans un textbox.
Le soucis c'est que la formule se traduit en ANGLAIS. (=SOMME(A1:A3) ----> devient SUM(A1:A3) )
Y-a-t'il moyen de les coller avec la formule se trouvant sur la feuille Excel

Un bout de code de ce que j'avais fait

Merci d'avance
Private Sub Btn_Coller_Click()
   
    ActiveCell.Copy
    TextBox1.Value = ActiveCell.Formula
    Selection.PasteSpecial Paste:=xlPasteFormulas, Operation:=xlNone, _
    SkipBlanks:=False, Transpose:=False
    Application.CutCopyMode = False
    
End Sub
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
f
frangy
Passionné d'Excel
Passionné d'Excel
Messages : 4'337
Appréciation reçue : 1
Inscrit le : 19 novembre 2012
Version d'Excel : 2007 FR

Message par frangy » 2 octobre 2016, 10:37

Bonjour,

Essaie avec :
TextBox1.Value = ActiveCell.FormulaLocal

A+
Avatar du membre
M12
Passionné d'Excel
Passionné d'Excel
Messages : 3'118
Appréciations reçues : 120
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 2 octobre 2016, 10:42

Bonjour Frangy

Nickel-Chrome,

Je ne connaissais pas
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message