Recherche valeur dans matrice et renvoi de valeur Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
j
j.winkler
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 16 avril 2014
Version d'Excel : 2013 FR

Message par j.winkler » 27 août 2016, 22:07

Salut à tous,

Je cherche une formule consistant à rechercher une valeur dans une matrice et me renvoyer une valeur texte déterminée par certaines conditions.

Pour illustrer mon problème, je vous invite à consulter le classeur Excel en pièce jointe.

Je souhaite insérer une fonction en F5. Cette fonction doit faire trois choses :
- rechercher dans la plage B2:B11 la valeur de E5 (ici c'est G)
- après avoir trouvé E5, elle doit vérifier la valeur correspondante dans la plage C2:C11 et faire la chose suivante ; si cette valeur est égale à E4 (ici 0) OU F4 (ici 2) la fonction doit me renvoyer "Oui", si cette condition n'est pas remplie elle doit me renvoyer "Non"

Merci pour votre aide!

Joris
Classeur2.xlsx
(8.18 Kio) Téléchargé 19 fois
A
Amadéus
Modérateur
Modérateur
Messages : 17'749
Appréciations reçues : 66
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 27 août 2016, 22:18

Bonjour
Formule en F5
=SI(NB.SI(E4:F4;RECHERCHEV(E5;$B$2:$C$11;2;0))>0;"Oui";"Non")
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
j
j.winkler
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 16 avril 2014
Version d'Excel : 2013 FR

Message par j.winkler » 28 août 2016, 12:36

Merci beaucoup Amadeus!! =)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message