Remplir un tableau à partir d'une feuille(3 critères) Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
l
lana
Membre habitué
Membre habitué
Messages : 68
Inscrit le : 18 août 2016
Version d'Excel : 2013

Message par lana » 22 août 2016, 16:34

Bonjour,
SVP j'ai besoin de votre aide pour faire une macro qui me permettra de remplir un tbaleau à paritr d'un autre selon 3 critères

dans le fichier joint j'explique l'objectif de la macro.
Meric bcp pour votre aide
MACRO A FAIRE .xlsm
(15.47 Kio) Téléchargé 25 fois
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 448
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 22 août 2016, 16:54

Bonjour,

Dans un cas pareil, une formule simple est plus facile à mettre en place !
=SOMMEPROD(('BASE DE DONNEES'!$A$2:$A$18=$B$2)*('BASE DE DONNEES'!$B$2:$B$18=$A7)*DECALER('BASE DE DONNEES'!$B$2:$B$18;;EQUIV(C$6;'BASE DE DONNEES'!$C$1:$N$1;0)))
Elle peut être améliorée et raccourcie en nommant 2 plages de données de la Base en dynamique...
Elle est recopiable (ici formulée pour C7) sur toutes les cellules concernées.

Cordialement.
l
lana
Membre habitué
Membre habitué
Messages : 68
Inscrit le : 18 août 2016
Version d'Excel : 2013

Message par lana » 22 août 2016, 17:06

Bonjour,
Merci mais en fait il fuat que je fasse ca pour plusieurs tableau et bcp plus de catégorie je ne peux pas taper la formule plusieurs fois .
Merci
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'050
Appréciations reçues : 387
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 22 août 2016, 17:38

Bonjour

Un essai à tester. Te convient-il ?
Bye !
MACRO A FAIRE v1.xlsm
(23.62 Kio) Téléchargé 29 fois
l
lana
Membre habitué
Membre habitué
Messages : 68
Inscrit le : 18 août 2016
Version d'Excel : 2013

Message par lana » 23 août 2016, 08:56

oui ça a l'air de marcher je vous remercie est ce que vous pouvez me commenter votre code pour que je puisse l'adapter svp
Merci énormément
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'050
Appréciations reçues : 387
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 23 août 2016, 10:02

Nouvelle version commentée.
Bye !
MACRO A FAIRE v1b.xlsm
(24.65 Kio) Téléchargé 49 fois
l
lana
Membre habitué
Membre habitué
Messages : 68
Inscrit le : 18 août 2016
Version d'Excel : 2013

Message par lana » 23 août 2016, 10:06

Mercii bcp
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message