Remplir un tableau à partir d'une feuille(3 critères)

Bonjour,

SVP j'ai besoin de votre aide pour faire une macro qui me permettra de remplir un tbaleau à paritr d'un autre selon 3 critères

dans le fichier joint j'explique l'objectif de la macro.

Meric bcp pour votre aide

25macro-a-faire.xlsm (15.47 Ko)

Bonjour,

Dans un cas pareil, une formule simple est plus facile à mettre en place !

=SOMMEPROD(('BASE DE DONNEES'!$A$2:$A$18=$B$2)*('BASE DE DONNEES'!$B$2:$B$18=$A7)*DECALER('BASE DE DONNEES'!$B$2:$B$18;;EQUIV(C$6;'BASE DE DONNEES'!$C$1:$N$1;0)))

Elle peut être améliorée et raccourcie en nommant 2 plages de données de la Base en dynamique...

Elle est recopiable (ici formulée pour C7) sur toutes les cellules concernées.

Cordialement.

Bonjour,

Merci mais en fait il fuat que je fasse ca pour plusieurs tableau et bcp plus de catégorie je ne peux pas taper la formule plusieurs fois .

Merci

Bonjour

Un essai à tester. Te convient-il ?

Bye !

oui ça a l'air de marcher je vous remercie est ce que vous pouvez me commenter votre code pour que je puisse l'adapter svp

Merci énormément

Nouvelle version commentée.

Bye !

Mercii bcp

Rechercher des sujets similaires à "remplir tableau partir feuille criteres"