extraire formule d'une cellule, vers un format texte

Y compris Power BI, Power Query et toute autre question en lien avec Excel
B
Bens
Membre habitué
Membre habitué
Messages : 62
Inscrit le : 27 février 2008
Version d'Excel : Mac 2011 FR

Message par Bens » 23 juin 2016, 16:52

Bonjour,

J'ai un tableau avec une très grande quantité de formules a priori identiques, sauf qu'il y a des incohérences à certains endroits. Tout n'est pas repérable par excel via l'outil de vérification d'erreurs intégrée.

Comme autre moyen, je cherche à connaitre la longueur des chaines de caractères qui composent les cellules. Mais il n'est pas possible d'utiliser NBCAR(-) pour compter la longueur d'une formule. A moins de convertir la formule au format texte… mais comment faire?

Pouvez-vous m'aider?
Merci
m
minanse
Membre dévoué
Membre dévoué
Messages : 693
Inscrit le : 1 juin 2016
Version d'Excel : 2007

Message par minanse » 23 juin 2016, 16:58

Bonjour,

je croie qu'on peut utiliser nbcar("cellule") sur un case à formule
A
Amadéus
Modérateur
Modérateur
Messages : 17'742
Appréciations reçues : 66
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 23 juin 2016, 16:59

Bonjour
"LIRE CELLULE : présenter en même temps une formule et son résultat
Dans une feuille Excel, quand vous tapez une formule, c'est son résultat qui s'affiche (par exemple 556,2...) et non la formule elle-même (par exemple =SOMME(A2:A6)/A9 ).Mais vous pouvez faire apparaître l'un et l'autre dans des cellules adjacentes ; à des fins pédagogiques, par exemple.
Dans notre exemple, nous voulons afficher en B7 le texte de la formule se trouvant immédiatement à gauche (donc en A7 ). Sélectionnez B7 et déroulez Insertion, Nom, Définir.
Dans le champ Noms dans le classeur, tapez Formule. Dans le champ Fait référence à, saisissez =LIRE.CELLULE(6;!A7) puis appuyez sur Entrée.
Tapez maintenant en B7 la formule =FORMULE et validez. Le texte de la formule de A7 apparaît maintenant en B7.
Désormais, si vous tapez =FORMULE dans n'importe quelle cellule du tableau, vous verrez s'afficher le texte de la formule placée à sa gauche. "
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message