Réunir deux formules matricielles Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
G
Gazou
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 25 février 2016
Version d'Excel : 2010 FR

Message par Gazou » 30 mai 2016, 02:39

Bonjour,

Je vous soumet le fichier joint qui contient trois onglets qui sont 1) une liste de membres, 2) une liste de non membres et 3) l'onglet modèle qui doit gérer ces deux listes. Mon problème se situe dans la cellule I6 de l'onglet modèle où il y a une erreur que je suis incapable de trouver.

Je désire que l'onglet I6 inscrive, dès que j'ai inscrit le prénom et le nom du membre, sa date de naissance à partir de la liste de membres. S'il ne trouve pas dans cette première liste, l'onglet I6 parcoure par la suite l'onglet non membres afin de trouver ce nom et prénom.

Vous constaterez dans les onglets I7 et I8 que j'ai réussi à trouver la formule pour effectuer cette tâche, mais il serait utile de combiner les deux formules en utilisant un si conditionnel afin d'effectuer le travail plus efficacement.

Merci pour votre aide

Daniel
Inscriptions (membre à corriger.xlsx
(165.45 Kio) Téléchargé 16 fois
Avatar du membre
M12
Passionné d'Excel
Passionné d'Excel
Messages : 3'237
Appréciations reçues : 129
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 30 mai 2016, 07:06

Bonjour,

A Tester en I6 et validation matricielle
=SI(J6="M";INDEX(Membres!$F$2:$F$499;EQUIV(C6&D6;Membres!$C$2:$C$499&Membres!$B$2:$B$499;0));SI(J6="NM";INDEX(NonMembres!$F$2:$F$499;EQUIV(C6&D6;NonMembres!C$2:C$499&NonMembres!$B$2:$B$499;0));""))
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
G
Gazou
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 25 février 2016
Version d'Excel : 2010 FR

Message par Gazou » 30 mai 2016, 15:11

Merci pour ta réponse, cela fonctionne à merveille.

Daniel
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message