Calcul de somme avec retenu SOMME.SI.ENS

Y compris Power BI, Power Query et toute autre question en lien avec Excel
m
mlegentil
Membre habitué
Membre habitué
Messages : 76
Inscrit le : 12 avril 2014
Version d'Excel : 2007

Message par mlegentil » 16 mai 2016, 12:52

Bonjour a tous,

Mon problème semble facile et simple à calculer (sur papier) mais le mettre en formule sur EXCEL l'est beaucoup moins.

Je gère l' envoi de produits blanc / (machine à laver et Frigo) et pour cela je dois calculer le Métrage plancher MPL de chaque envoi.

Par produit : le calcule du MPL est réalisé suivant les contraintes posées (LONG - LARG et HAUTEUR) du camion.
Par famille de produit : je ne vois par comment tourner ma formule

Par exemple
BLANC LAV x3 : ja'i 2 gammes de produits à envoyer
Produit 1 : 4 - Largeur 66 - prof 65 - 0,65MPL (2 emplacements disponible)
Produit 2 : 7 - Largeur 70 - prof 68 - 1,36 MPL (5 emplacements disponible)

Et si on doit additionner le métrage plancher de ses 2 produits soit au total 11 article,s on ne doit pas trouver 2.01 mais 1.36MPL.

Je ne sais pas si vous avez tout compris.

Merci de votre aide.
test tri.xlsx
(16.33 Kio) Téléchargé 33 fois
m
mlegentil
Membre habitué
Membre habitué
Messages : 76
Inscrit le : 12 avril 2014
Version d'Excel : 2007

Message par mlegentil » 16 mai 2016, 20:07

En fouillant sur le forum, j'ai constaté que le fond de mon problème ressort du domaine de la programmation linéaire c’est à dire optimiser les espaces (coût, rentabilité ...) et du coup je dois utiliser le module Excel Plug-in Solveur. Ai-je le choix ?

Dois-je réellement passer par ça.

Voici ce que je pense être une solution : vous en pensez ! quoi
En utilisant des formules de tri - croissant associer à des SOMMEPROD et du GRANDE.VALEUR, je pense qu'on peut solutionner mon problème.
- 1 D'abord : trier chaque CAT (tri alphanumérique) et classer par ordre GRANDE.VALEUR les profondeurs des produits
- 2 Optimiser chaque ligne de rangement dans le camion non utilisé en utilisant des calcules simples pour identifier les RETENU de places
- 3 Utiliser la fonction SOMMEPROD pour chaque CAT

Formule pour trier les catégories:

=SI($P23="";"";NB.SI($P$23:$P$31;">"&$P23)+1) Admettons que cette formule commence à la cellule R23

Formule pour classer les catégories (à trouver la formule si par ordre de grandeurs des profondeurs . Admettons que cette formule commence à la cellule S23

SI(NB(R$22:R$31)+1>NBVAL(s$22sC22);RECHERCHEV(GRANDE.VALEUR(r$23:r$31;LIGNES($22:22));r$23:r$31;2;0);"")

Merci de vos aides.

Michel
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message