Compter le nombre de plusieurs valeurs selon criteres Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
d
drislouk69200
Jeune membre
Jeune membre
Messages : 34
Inscrit le : 7 février 2011
Version d'Excel : 2003 FR

Message par drislouk69200 » 17 mars 2016, 15:38

Hello a tous,

Tout d'abord veuillez m'excuser du manque d'accent, j'ecris d'un clavier etranger. :)

J'ai besoin de votre aide pour trouver une formule que je n'arrive bien sur pas a trouver moi meme et meme avec mon meilleur ami Google on a du mal...

Comme vous le verrez dans le fichier joint, j'ai un tableau qui est un planning ou je souhaite calculer le % d'actions realisees sur le total des actions par semaine (jusque la ca va...). Cependant, dans la colonne "methode", je peux choisir entre A, B ou C, et selon cette selection j'aimerai que cela incremente les valeurs de la zone A, B ou C (en haut de mon tableau).

Voila j'espere avoir ete assez clair sinon n'hesitez pas a me poser des questions.

Bonne journee a vous tous et merci d'avance !

Clement
Compter selon valeurs + criteres pouvant changer.xlsx
(11.24 Kio) Téléchargé 19 fois
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'804
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 17 mars 2016, 15:45

Bonjour,
si j'ai bien compris
en D3 :
=NB.SI.ENS($B$14:$B$31;$A$3;D$14:D$31;"?")
en D4 :
=NB.SI.ENS($B$14:$B$31;$A$3;D$14:D$31;"R")
les 2 formules à tirer vers la droite

à adapter pour B et C.


@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 17 mars 2016, 15:51

bonjour

il faut d'abord défusionner (ne jamais jamais fusionner dans Excel ! )
puis des SOMMEPROD
voir ici
Copie de Compter selon valeurs + criteres pouvant changer.xlsx
(12.65 Kio) Téléchargé 24 fois
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
d
drislouk69200
Jeune membre
Jeune membre
Messages : 34
Inscrit le : 7 février 2011
Version d'Excel : 2003 FR

Message par drislouk69200 » 17 mars 2016, 15:58

Tout d'abord merci a vous deux,

JMD, malheureusement ta formule ne marche par car elle n'incremente pas correctement, je m'explique :

- Initialement par colonne tu as deja compte 13 et 15 alors que je n'ai que 11 valeur au total.
- Aussi, quand je change la methode dans la colonne de gauche, cela incremente aleatoirement et non selon les valeurs (R, N, E ou P)

R@chid, je vais essaye comme ca de suite et je vous fais un retour.

A+

Clement

Rachid je viens d'essayer et cela ne fonctionne pas car :

POUR CHAQUE METHODE (A, B et C): Je veux compter l'addition de P+R+E+N sur une premiere ligne et compter seulement les R sur une deuxieme ligne.

++

ERRATUM : Rachid ca marche ! Je n'avais pas bien recopier la formule....

Pour la premiere ligne j'ai utilise :

=COUNTIFS($B$14:$B$31,$A$3,D$14:D$31,"R")+COUNTIFS($B$14:$B$31,$A$3,D$14:D$31,"p")+COUNTIFS($B$14:$B$31,$A$3,D$14:D$31,"E")+COUNTIFS($B$14:$B$31,$A$3,D$14:D$31,"N")

Pour la deuxieme, seulement ;

=COUNTIFS($B$14:$B$31,$A$3,D$14:D$31,"R")

Encore merci

Clement
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 17 mars 2016, 16:40

re à vous

oups !
je faisais le bilan de tout le tableau alors que tu veux par semaine
voici corrigé, toujours avec SOMMEPROD)
Copie de Copie de Compter selon valeurs + criteres pouvant changer.xlsx
(12.61 Kio) Téléchargé 27 fois
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message