cumul de fonction SI ET Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
e
esfac2b
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 14 janvier 2016
Version d'Excel : 2013FR

Message par esfac2b » 7 mars 2016, 10:37

Bonjour,
J'essaye de calculer un tarif en fonction du cumul de 2 listes déroulantes.

En A11, j'ai une liste qui m'offre 4 choix : Mois, Trimestre, Année, 10 séances.
En D14, j'ai le résultat de cette 1ère liste : 74€, 170€, 520€, 80€
En A14, j'ai une 2ème liste qui m'offre 3 choix : -de 20 ans, Adulte, Couple.

En G14, je voudrais le résultat du cumul des 2 listes ce qui me donne 12 possibilités. J'arrive a établir la 1ère condition mais je ne parviens pas à cumuler d'autres conditions. Voici le début de formule que j'ai écrit :

=SI(ET(A11="Mois";A14="- de 20 ans");D14*0,92)

D'avance merci pour votre aide
Avatar du membre
oyobrans
Membre impliqué
Membre impliqué
Messages : 1'006
Appréciations reçues : 14
Inscrit le : 27 septembre 2013
Version d'Excel : 2016

Message par oyobrans » 7 mars 2016, 10:42

Bonjour,

Quelles sont toutes les possibilités ? Tu pourrais peut-être utiliser un tableau à double entrée. Joins un fichier éventuellement.
Cordialement.

Aide-toi et le ciel t'aidera.
[ GIF animé de Dave Whyte ]
Avatar du membre
bernard22
Membre dévoué
Membre dévoué
Messages : 882
Appréciations reçues : 11
Inscrit le : 26 mars 2015
Version d'Excel : 2013FR

Message par bernard22 » 7 mars 2016, 10:43

Bonjour,
Merci de joindre un fichier à ta demande
e
esfac2b
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 14 janvier 2016
Version d'Excel : 2013FR

Message par esfac2b » 7 mars 2016, 10:56

Bonjour,
Voici le fichier en question
Fichier client exemple.xlsx
(10.99 Kio) Téléchargé 14 fois
Avatar du membre
bernard22
Membre dévoué
Membre dévoué
Messages : 882
Appréciations reçues : 11
Inscrit le : 26 mars 2015
Version d'Excel : 2013FR

Message par bernard22 » 7 mars 2016, 11:16

Bonjour,
en g14 tu peux continuer ta formule:
=SI(ET(A11="Mois";A14="- de 20 ans");D14*0,92;SI(ET(A11="Année";A14="- de 20 ans");"an-20";"suite"))
Mais la formule serait assez longue
ou
Passer par une table : Voir fichier joint
Fichier client exemple01.xlsx
(11.58 Kio) Téléchargé 29 fois
Avatar du membre
oyobrans
Membre impliqué
Membre impliqué
Messages : 1'006
Appréciations reçues : 14
Inscrit le : 27 septembre 2013
Version d'Excel : 2016

Message par oyobrans » 7 mars 2016, 12:15

Il faudrait la grille de tarifs pour répondre de façon précise.
Cordialement.

Aide-toi et le ciel t'aidera.
[ GIF animé de Dave Whyte ]
e
esfac2b
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 14 janvier 2016
Version d'Excel : 2013FR

Message par esfac2b » 7 mars 2016, 13:36

Je ne connaissais pas l'utilisation d'une table. Ça me semble effectivement très approprié à ce que je souhaite faire. Par contre, la table que vous m'avez envoyée ne fonctionne que sur la moitié des conditions à savoir sur Mois et Trimestre et ne fonctionne plus à partir de Année et 10 séances.
J'ai recherché comment fonctionnent les fonctions CNUM et RECHERCHEV et je ne vois pas ce qui "cloche" dans la table que vous avez fait. Y a t-il un nombre limité de conditions dans une table ou ai je fait une erreur ?

Encore merci pour votre aide.
Avatar du membre
bernard22
Membre dévoué
Membre dévoué
Messages : 882
Appréciations reçues : 11
Inscrit le : 26 mars 2015
Version d'Excel : 2013FR

Message par bernard22 » 7 mars 2016, 13:42

Bonjour,
La table était à trier. (je l'avais remise dans cet ordre pour vous aider à la remplir).
Fichier client exemple02.xlsx
(11.63 Kio) Téléchargé 14 fois
e
esfac2b
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 14 janvier 2016
Version d'Excel : 2013FR

Message par esfac2b » 7 mars 2016, 14:03

Merci beaucoup, tout fonctionne, c'est génial.
Quand vous dites "trier la table", c'est par ordre alphabétique ? J'aime bien comprendre ce que je fais afin d'apprendre et de pouvoir reproduire par moi même.
Encore merci pour votre aide et votre disponibilité.
Avatar du membre
bernard22
Membre dévoué
Membre dévoué
Messages : 882
Appréciations reçues : 11
Inscrit le : 26 mars 2015
Version d'Excel : 2013FR

Message par bernard22 » 7 mars 2016, 14:07

De rien
Merci de marquer le sujet comme "Résolu"
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message