compter les cellules en fonction des 3 dernieres dates Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
i
ian972
Membre fidèle
Membre fidèle
Messages : 179
Inscrit le : 14 février 2013
Version d'Excel : 2010

Message par ian972 » 26 février 2016, 16:13

bonjour a tous, bonjour a chacun

je sollicite le forum pour la difficulté suivante :

je souhaite compter (NB.SI.ENS) le %de reussite de chaque vendeurs par periode de 3 jours glissantes suivant le lieu de realisation dans un tableau que j actualise tous les jours (en fichiers joint).

je pense devoir utiliser les fonctions NB.SI.ENS, DECALER ou DATE mais je ne sais dans quel ordre.

Donc la difficulté est de faire glisser a chaque actualisation les valeurs prises en compte.

Par exemple si je choisis mon vendeurs BOB a Lyon en cellule G12 je devrais retrouver 42%.

j ai joint un fichier

Vous remerciant

Ian
compter de date a date.xlsx
(11.08 Kio) Téléchargé 12 fois
A
Amadéus
Modérateur
Modérateur
Messages : 17'739
Appréciations reçues : 69
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 26 février 2016, 17:38

Bonjour
avec la formule matricielle (Validation avec les 3 touches Ctrl+Maj+Entrée)
=SOMMEPROD(($A$2:$A$12>=(MIN(GRANDE.VALEUR(SI(($B$2:$B$12="bob")*($A$2:$A$12>0)*($C$2:$C$12="lyon");$A$2:$A$12);{1;2;3}))))*($B$2:$B$12="bob")*($C$2:$C$12="lyon")*($F$2:$F$12))/3
Je trouve 48,3 (soit 145/3)
Cordialement
compter de date a date.xlsx
(11.17 Kio) Téléchargé 12 fois
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
i
ian972
Membre fidèle
Membre fidèle
Messages : 179
Inscrit le : 14 février 2013
Version d'Excel : 2010

Message par ian972 » 26 février 2016, 18:20

Bonjour Amadeus.

Merci avoir pris le temps de repondre a ma demande.

j ai testé la proposition et elle me convient .

Je te remercie grandement pour ton aide.

Un bon week end a toi.

ian
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message