Calcul élection [Résolu] Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
l
lolo2b82
Membre habitué
Membre habitué
Messages : 55
Inscrit le : 13 février 2016
Version d'Excel : 2019

Message par lolo2b82 » 13 février 2016, 10:31

Bonjour,

Je souhaiterai calculer automatiquement le résultat d'élection syndicale mais je sèche.
Pour faire le plus simple possible, il y a 3 listes pour 3 sièges.
Celui qui a le plus de votes obtient un siège, puis on lui divise ses votes par 2.
A nouveau celui qui a le plus de votes obtient un siège, auquel on divise encore par 2.
Et enfin, celui a qui il reste le plus de votes obtient le dernier siège.

En gros a chaque fois qu'une liste obtient un siège on lui divise par 2 ses votes.

J'ai essayé avec SI et MAX mais je tourne en rond.

Merci
Modifié en dernier par lolo2b82 le 13 février 2016, 12:33, modifié 1 fois.
Avatar du membre
OOoiste
Membre impliqué
Membre impliqué
Messages : 1'574
Appréciations reçues : 14
Inscrit le : 1 octobre 2009
Version d'Excel : office 365

Message par OOoiste » 13 février 2016, 10:51

Bonjour,

Un exemple, sous forme de tableau (avec autant de colonnes que de sièges à pourvoir).
élections.jpg
election.xlsx
(5.25 Kio) Téléchargé 46 fois
A+
l
lolo2b82
Membre habitué
Membre habitué
Messages : 55
Inscrit le : 13 février 2016
Version d'Excel : 2019

Message par lolo2b82 » 13 février 2016, 11:05

Merci pour ton aide, je connaissais pas GRANDE.VALEUR et je comprend pas trop ce que ça calcul :shock: .

Avec SI et MAX j'ai réussis mais j'aurais souhaité tout calculer sur une même cellule.
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'201
Appréciations reçues : 444
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 13 février 2016, 11:32

OOiste :bien:

Dans la foulée de cette magnifique démonstration, je me suis essayé à calculer le nombre de sièges en une seule formule.

Les voix se trouvant en A1, A2, A3 ; formule sur la ligne 1 (ou n'importe quelle, elle sera tirable vers le bas).
=SOMMEPROD(--(A1*{1;0,5;0,25}>GRANDE.VALEUR($A$1:$A$3*{1.0,5.0,25};4)))
Cordialement.
l
lolo2b82
Membre habitué
Membre habitué
Messages : 55
Inscrit le : 13 février 2016
Version d'Excel : 2019

Message par lolo2b82 » 13 février 2016, 11:40

On touche au but :D ... ta formule marche très bien ! mais mes résultats sont en ligne comment adapter ta formule ?
MFerrand a écrit :OOiste :bien:

Dans la foulée de cette magnifique démonstration, je me suis essayé à calculer le nombre de sièges en une seule formule.

Les voix se trouvant en A1, A2, A3 ; formule sur la ligne 1 (ou n'importe quelle, elle sera tirable vers le bas).
=SOMMEPROD(--(A1*{1;0,5;0,25}>GRANDE.VALEUR($A$1:$A$3*{1.0,5.0,25};4)))
Cordialement.
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'201
Appréciations reçues : 444
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 13 février 2016, 11:49

Le cas échéant mets un modèle...
Je pense que dans la matrice de la fonction GRANDE.VALEUR, le séparateur point (.) doit être remplacé par un point-virgule (;).
Pour la première matrice, ce ne devrait pas être le cas (inutile d'inverser le style de séparateur je pense)...
NB- le . définit une matrice en ligne et le ; une matrice colonne...

A essayer (il suffit de trouver la bonne position pour qu'Excel fasse le calcul !)

C'est bien ça. Je viens d'essayer.
Bon weekend.
l
lolo2b82
Membre habitué
Membre habitué
Messages : 55
Inscrit le : 13 février 2016
Version d'Excel : 2019

Message par lolo2b82 » 13 février 2016, 12:32

Je comprend rien a la formule mais ça marche impeccable.. Vous êtes des dieux merci !
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message