Un nouveau soucis s'offre à moi. Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Y
Yann69
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 31 octobre 2015
Version d'Excel : 2016

Message par Yann69 » 3 février 2016, 02:57

Bonjour à tous,

J'ai un nouveau soucis que je rencontre avec mon planning et que je ne pouvais pas voir en décembre et en janvier car 31 jours.

Il y a un soucis dans les formules calculant les dimanches dans la partie statistiques. J'ai un #VALEUR qui s'affiche dans ses cases :(
En X7 et Y7.

Mot de passe en cas de besoin : Ne pas toucher

Pourriez-vous m'aider à trouver le soucis svp.
Je suis sûr que ça a un rapport avec les mois à moins de 31 jours mais je ne vois pas comment résoudre le problème.

Merci par avance.
Yann

Le fichier est à téléchargé ici car trop gros pour être hébergé sur le forum :(
http://dl.free.fr/jU66UtgF2
Avatar du membre
Banzai64
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'726
Appréciation reçue : 1
Inscrit le : 21 novembre 2010
Version d'Excel : 2003 FR (learning 2010 - 2013)

Message par Banzai64 » 3 février 2016, 03:37

Bonjour

Une solution
Pour le mois de Février (sera valable pour l'année prochaine)
Formule à modifier en C38 et à tirer vers le bas
=SIERREUR(SI(D38=0;0;SI(NB.SI(Fériés;D38)>0;"Férié";SI(JOURSEM(D38;2)<=6;"Se";"Dim")));"")
Pour les mois en 30 jours
Formule à modifier en C40
=SIERREUR(SI(D40=0;0;SI(NB.SI(Fériés;D40)>0;"Férié";SI(JOURSEM(D40;2)<=6;"Se";"Dim")));"")
Image
Y
Yann69
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 31 octobre 2015
Version d'Excel : 2016

Message par Yann69 » 3 février 2016, 03:39

Merci pour la solution Banzai. Je vais tester ça.
Par contre, je ne comprend pas trop de quoi tu parles quand tu dis (pour l'année prochaine ) ?
Nous sommes encore en février donc je dois corriger l'erreur pour ce mois-ci aussi.

Petit aparté, je me doutai que tu allais passer par ici mais pas à cette heure aussi tardive :D
Avatar du membre
Banzai64
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'726
Appréciation reçue : 1
Inscrit le : 21 novembre 2010
Version d'Excel : 2003 FR (learning 2010 - 2013)

Message par Banzai64 » 3 février 2016, 03:54

Bonjour

En 2016 Février compte 29 jours et on serait tenté de corrigé à partir de la cellule C39 (cellule à partir de laquelle il y a une erreur)
Mais si tu utilises le même fichier en 2017, Février n'ayant que 28 jours, la formule en C38 te renverra une erreur et problème que tu as actuellement sera présent pour Février 2017

Mais je vais voir si mon lit est toujours au même endroit

:dodo:
Image
Y
Yann69
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 31 octobre 2015
Version d'Excel : 2016

Message par Yann69 » 3 février 2016, 03:56

Re-bonjour,

Alors que puis-je faire pour que ce soucis soit réglé définitivement pour tous les mois des février de ces prochaines années stp ?
Car il arrivera bien un moment ou un mois de février en 29 jours reviendra.

Et comme ce fichier est partagé avec ceux travaillant dans la même branche que moi, il faudrait que ce soucis se règle avant que je le partage à nouveau.
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'417
Appréciations reçues : 496
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR

Message par Steelson » 3 février 2016, 07:02

Yann69 a écrit : pour tous les mois des février de ces prochaines années stp ?
Car il arrivera bien un moment ou un mois de février en 29 jours reviendra.
dès cette année !

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Y
Yann69
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 31 octobre 2015
Version d'Excel : 2016

Message par Yann69 » 4 février 2016, 02:49

Bah oui je sais bien pour le 29 ce mois ci :)

Mais ça ne résous pas trop mon soucis dans ce cas. Quelqu'un qui aurait la solution svp ?
Avatar du membre
Banzai64
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'726
Appréciation reçue : 1
Inscrit le : 21 novembre 2010
Version d'Excel : 2003 FR (learning 2010 - 2013)

Message par Banzai64 » 4 février 2016, 03:34

Bonjour
Yann69 a écrit :Mais ça ne résous pas trop mon soucis dans ce cas. Quelqu'un qui aurait la solution svp ?
As tu fait les corrections que j'ai proposées ?

Il y a quelque chose qui m'échappe ?
Image
Y
Yann69
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 31 octobre 2015
Version d'Excel : 2016

Message par Yann69 » 4 février 2016, 03:35

Bonjour Banzai,

Oui oui j'ai bien fait les corrections que tu décris sauf pour février puisque tu m'as dit que ça ne fonctionnerait que pour l'année prochaine avec un mois en 28 jours. N'aurais-je pas tout compris ?
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message