Traduire un sommeprod en nb.si.ens Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
E
Emil
Membre fidèle
Membre fidèle
Messages : 218
Inscrit le : 9 février 2010
Version d'Excel : 2007e & 2010f

Message par Emil » 6 octobre 2015, 20:17

Bonjour forum,

j'ai cette formule:
=SOMMEPROD((H2:H225="V")*(MOIS(B2:B225)=4)*1)
qui compte le nombre de cas qui répond à 2 critères: caractère: V présent dans la colonne H et dont la date indiquée dans la colonne B se situe au mois d'avril.

Quelqu'un aurait-il une idée comment écrire le tout avec la formule: NB.SI.ENS() ?

Merci d'avance
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'804
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 6 octobre 2015, 20:22

Bonsoir,
essayer comme ça :
=NB.SI.ENS(H2:H225;"V";B2:B225;">="&"1/4/2015"*1;B2:B225;"<="&"30/4/2015"*1)


@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
E
Emil
Membre fidèle
Membre fidèle
Messages : 218
Inscrit le : 9 février 2010
Version d'Excel : 2007e & 2010f

Message par Emil » 6 octobre 2015, 20:31

Bonjour Rachid,

Je te remercie pour ta réponse. Maintenant, j'ai oublié de dire que la colonne: des date peut s'échelonner sur plusieurs années. En d'autres mots, mon deuxième critère ne concerne que le mois d'avril de n'importe lequel année. C'est là que ça se complique!

Emil
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'804
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 7 octobre 2015, 00:31

Re,
pourrais-tu joindre un fichier exemple ?
on peut le faire via TCD, ou avec NB.SI.ENS et une colonne auxiliaire.

@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
E
Emil
Membre fidèle
Membre fidèle
Messages : 218
Inscrit le : 9 février 2010
Version d'Excel : 2007e & 2010f

Message par Emil » 7 octobre 2015, 22:48

Bonjour R@chid,

après plusieurs essais, je me suis résigné a utiliser une colonne supplémentaire qui indique les mois, ce qui rend l'utilisation de la fonction: NB.SI.ENS beaucoup plus aisée.

Je te remercie,
Émil
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message