Compter le nombre d'occurrences d'une référence Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
R
Reboot
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 18 avril 2013
Version d'Excel : 2010

Message par Reboot » 30 juillet 2015, 11:03

Bonjour à tous,

J'ai sur mon fichier une liste de 1000 adresses URL.

J'aimerais obtenir la répartition de ces URLs par répertoire, par exemple :

http://www.site.fr/economie/ = 200 URLs
http://www.site.fr/sport/ = 50 URLs
http://www.site.fr/france/ = 150 URLs

J'utilise donc la fonction NB.SI
=NB.SI(A1:A1000;"http://www.site.fr/economie*")
qui fonctionne parfaitement, et me donne le nombre d'URLs qui commencent par "http://www.site.fr/economie"

L'inconvénient cependant, est que la formule ne prend en compte que le texte. J'aimerais beaucoup remplacer le texte par une référence (ex. C2) afin d'éviter de devoir taper manuellement le texte dans chaque formule.

La formule
=NB.SI(A1:A1000;C2)
(En C2, on trouve une cellule format texte http://www.site.fr/economie) ne fonctionne évidemment pas, ça aurait été trop simple... :mrgreen:

Après beaucoup de recherches je n'ai pas réussi à trouver la bonne mise en forme permettant d'utiliser une référence au lieu d'un texte entre "", peut-être qu'elle n'existe pas?

Merci de m'éclairer ::D
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'976
Appréciations reçues : 359
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 30 juillet 2015, 11:09

bonjour,

ajoute un "*" à la fin de ta cellule en C2

ou change ta formule
=NB.SI(A1:A1000; C2 & "*")
R
Reboot
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 18 avril 2013
Version d'Excel : 2010

Message par Reboot » 30 juillet 2015, 11:16

Wow, c'était si simple :lol:


Un gros merci pour cette réponse exacte et ultra-rapide :D
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message