Problème formule INDEX

Y compris Power BI, Power Query et toute autre question en lien avec Excel
S
Seb334
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 2 juin 2015
Version d'Excel : 2010

Message par Seb334 » 29 juin 2015, 19:41

Bonjour,

j'utilise la fonction INDEX pour rechercher une valeur. Cette formule m'a été tranféré par un membre de ce forum :) .
Celle-ci fonctionne très bien tant que je ne la modifie pas. Dès que je la modifie, j'ai une erreur #VALEUR!

Quand ça fonctionne la formule apparait {=INDEX(calcul!$C$1:$C$9;EQUIV(I6&J6;calcul!$A$1:$A$9&calcul!$B$1:$B$9;0))}
Dès que je modifie la formule, les {} disparrassent et elle apparait =INDEX(calcul!$C$1:$C$9;EQUIV(I6&J6;calcul!$A$1:$A$9&calcul!$B$1:$B$9;0)) et après j'ai l'erreur #VALEUR!

Je vous joint le fichier.

Merci pour votre aide :D

Sébastien
energie macro formulaire essai 3.xlsm
(38.08 Kio) Téléchargé 4 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'143
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 29 juin 2015, 20:01

Bonjour,

il s'agit d'une formule matricielle, à valider par ctrl-maj-entrée.
S
Seb334
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 2 juin 2015
Version d'Excel : 2010

Message par Seb334 » 29 juin 2015, 21:48

Merci pour cette réponse super rapide! :D
Je teste demain et je te dis.
Sinon j'aime bien ton pseudo (acide sulfurique) tu bosses dans la chimie?
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message