FONCTION SI et RECHECHEV imbriqué Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
m
marions1857
Membre fidèle
Membre fidèle
Messages : 168
Inscrit le : 8 mai 2015
Version d'Excel : 2010

Message par marions1857 » 3 juin 2015, 15:28

Bonjour à toutes et à tous,

Ma fonction fonctionne mais retourne l'inverse de ce que je voudrais.
=SI(B2="";"";SI(ESTERREUR(RECHERCHEV(B2;$E$2:$E$17;1;0));"OUI";"NON"))
C'est à dire quand la valeur qui se trouve en B2 est bien présente dans le tableau (E2:E17), la fonction me retourne non alors que quand la valeur qui se en B2 n'est pas présente dans le tableau (E2:E17), ma fonction retourne OUI alors que cela devrait être l'inverse.
Quelqu'un serait comment faire pour régler cette erreur ?!

pour forum.xlsx
(10.9 Kio) Téléchargé 17 fois
Modifié en dernier par marions1857 le 3 juin 2015, 16:01, modifié 3 fois.
Avatar du membre
renyeu
Membre fidèle
Membre fidèle
Messages : 226
Appréciation reçue : 1
Inscrit le : 29 octobre 2011
Version d'Excel : LibreOffice 5.1.5.2

Message par renyeu » 3 juin 2015, 15:45

Bonjour,
A tester:
=SI(B2="";"";SI(ESTERREUR(RECHERCHEV(B2;$E$2:$E$17;1;0));"NON";"OUI"))
Cdlt
Renyeu
m
marions1857
Membre fidèle
Membre fidèle
Messages : 168
Inscrit le : 8 mai 2015
Version d'Excel : 2010

Message par marions1857 » 3 juin 2015, 15:47

J'ai déjà testé cela fonctionne mais n'est pas ce que je recherche. Je veux que la formule soit juste et non pas "bidouiller".
En tout cas merci pour votre réponse !
Avatar du membre
renyeu
Membre fidèle
Membre fidèle
Messages : 226
Appréciation reçue : 1
Inscrit le : 29 octobre 2011
Version d'Excel : LibreOffice 5.1.5.2

Message par renyeu » 3 juin 2015, 15:51

J'ai déjà testé cela fonctionne mais n'est pas ce que je recherche
:?: :?
Que cherches-tu :?: :?:
Quid de la bidouille si ça marche :roll:
Cdlt
Renyeu
A
Amadéus
Modérateur
Modérateur
Messages : 17'701
Appréciations reçues : 76
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 3 juin 2015, 15:54

Bonjour
Pourquoi un RECHERCHEV ?
=SI(B2="";"";SI(NB.SI($E$2:$E$17;B2);"OUI";"NON"))
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
m
marions1857
Membre fidèle
Membre fidèle
Messages : 168
Inscrit le : 8 mai 2015
Version d'Excel : 2010

Message par marions1857 » 3 juin 2015, 15:55

J'aimerai que ça fonctionne avec la formule telle qu'elle devrait être écrite et non pas telle que je l'ai écrite pour qu'elle fonctionne ! Je veux comprendre pourquoi cela me donne l'inverse de ce que ca devrait me donner !

Bonjour,

Parce que pour moi c'était la formule qui fallait utiliser. Je ne savais pas qu'on pouvait utiliser NB.SI !
Merci beaucoup :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Fonction RTD et RECHECHEV
    par MKHS » 2 novembre 2017, 16:25 » dans Excel - VBA
    7 Réponses
    198 Vues
    Dernier message par James007
    3 novembre 2017, 13:46
  • Fonction si imbrique
    par Sirouu » 17 juin 2018, 20:10 » dans Excel - VBA
    2 Réponses
    72 Vues
    Dernier message par Sirouu
    17 juin 2018, 21:32
  • Fonction si imbriqué
    par Atoto » 31 décembre 2018, 22:42 » dans Excel - VBA
    4 Réponses
    142 Vues
    Dernier message par Atoto
    1 janvier 2019, 10:30
  • Fonction SI imbriqué
    par zephir25 » 27 juin 2017, 16:43 » dans Excel - VBA
    9 Réponses
    216 Vues
    Dernier message par Raja
    28 juin 2017, 10:15
  • Fonction recherche v et si imbriqué
    par BenExcel » 30 octobre 2016, 02:15 » dans Excel - VBA
    3 Réponses
    304 Vues
    Dernier message par BenExcel
    30 octobre 2016, 14:00
  • Fonction RechercheV ? SI imbriqué ?
    par neelix » 6 janvier 2016, 08:58 » dans Excel - VBA
    2 Réponses
    332 Vues
    Dernier message par neelix
    6 janvier 2016, 09:21