FONCTION SI et RECHECHEV imbriqué

Bonjour à toutes et à tous,

Ma fonction fonctionne mais retourne l'inverse de ce que je voudrais.

=SI(B2="";"";SI(ESTERREUR(RECHERCHEV(B2;$E$2:$E$17;1;0));"OUI";"NON"))

C'est à dire quand la valeur qui se trouve en B2 est bien présente dans le tableau (E2:E17), la fonction me retourne non alors que quand la valeur qui se en B2 n'est pas présente dans le tableau (E2:E17), ma fonction retourne OUI alors que cela devrait être l'inverse.

Quelqu'un serait comment faire pour régler cette erreur ?!


17pour-forum.xlsx (10.90 Ko)

Bonjour,

A tester:

=SI(B2="";"";SI(ESTERREUR(RECHERCHEV(B2;$E$2:$E$17;1;0));"NON";"OUI"))

Cdlt

Renyeu

J'ai déjà testé cela fonctionne mais n'est pas ce que je recherche. Je veux que la formule soit juste et non pas "bidouiller".

En tout cas merci pour votre réponse !

J'ai déjà testé cela fonctionne mais n'est pas ce que je recherche

Que cherches-tu

Quid de la bidouille si ça marche

Cdlt

Renyeu

Bonjour

Pourquoi un RECHERCHEV ?

=SI(B2="";"";SI(NB.SI($E$2:$E$17;B2);"OUI";"NON"))

Cordialement

J'aimerai que ça fonctionne avec la formule telle qu'elle devrait être écrite et non pas telle que je l'ai écrite pour qu'elle fonctionne ! Je veux comprendre pourquoi cela me donne l'inverse de ce que ca devrait me donner !


Bonjour,

Parce que pour moi c'était la formule qui fallait utiliser. Je ne savais pas qu'on pouvait utiliser NB.SI !

Merci beaucoup

Rechercher des sujets similaires à "fonction rechechev imbrique"