Problème RechecheV #N/A Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
A
Alex74330
Jeune membre
Jeune membre
Messages : 44
Inscrit le : 15 avril 2015
Version d'Excel : EXCEL 2010

Message par Alex74330 » 21 avril 2015, 10:14

Bonjour à tous,

J'ai un problème avec une fonction Recherchev qui me parait pourtant très simple. Celà est peut être dû au 2 feuilles ?

Dans mon fichier j'essaye de retrouver une date en fonction de la référence "Offre" ou "Dossier" présent dans la feuille matrice.
Ma formule est =RECHERCHEV(A2;matrice!$A$1:$D$928;42;FAUX)
Sachant que ma valeur cherchée est en A2, cette valeur est cherchée dans la feuille matrice qui doit ensuite extraire la date colonne numéro 4. Et j'aimerai une valeur exacte mais tout ce que j'ai est #N/A..
Si vous avez des solutions, je suis preneur :)

Je vous joins mon fichier test pour que vous puissiez voir par vous-même.
RechercheV.xlsx
(54.58 Kio) Téléchargé 15 fois
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 21 avril 2015, 10:43

Bonjour,

Si j'ai correctement compris ta demande ... :wink:
RechercheV.xlsx
(55.29 Kio) Téléchargé 16 fois
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
A
Alex74330
Jeune membre
Jeune membre
Messages : 44
Inscrit le : 15 avril 2015
Version d'Excel : EXCEL 2010

Message par Alex74330 » 21 avril 2015, 10:54

Re James007,

Te revoilà à mon secours et comme toujours ca marche ! ;)
Pour que ce soit parfait il faudrait juste une petite modification, dans le fichier de nombreux offres et dossier n'ont pas de date "RO", le résultat par défaut est donc "00/01/00". J'ai vu que tu as dejà imbriqué un SIERREUR, alors comment faire pour ecrire "Date non existante" à la place de cette fameuse date ?

Une fois n'est pas coutume, un grand merci !! :D
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 21 avril 2015, 12:31

Re,

Content que cela fonctionne .. :wink:

Ci-joint ton fichier modifié en Version 2 ...
RechercheV V2.xlsx
(57.94 Kio) Téléchargé 17 fois
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'170
Appréciations reçues : 636
Inscrit le : 27 août 2012
Version d'Excel : 365 Personnel

Message par Jean-Eric » 21 avril 2015, 13:04

Bonjour,
Bonjour james007,
Une alternative avec tableaux et fonction RECHERCHEV.
Cdlt.
RechercheV V2.xlsx
(54.47 Kio) Téléchargé 11 fois
=SIERREUR(SI(RECHERCHEV(GAUCHE([@[Offre / Dossier]];7);Tableau1;4;FAUX)=0;"Date inconnue";
RECHERCHEV(GAUCHE([@[Offre / Dossier]];7);Tableau1;4;FAUX));"Dossier inconnu")
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
A
Alex74330
Jeune membre
Jeune membre
Messages : 44
Inscrit le : 15 avril 2015
Version d'Excel : EXCEL 2010

Message par Alex74330 » 21 avril 2015, 13:33

Bonjour,

Merci à vous deux pour votre aide et vos conseils, j'arrive de mieux en mieux à comprendre comment marche ces formules Excel !

Ce post est désormais résolu ! :mrgreen:
A bientôt !
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 21 avril 2015, 13:35

Re,

Jean-Eric et moi-même te remercions pour tes remerciements ... :wink:
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message