mettre calendrier perpetuel Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
julien35000
Membre dévoué
Membre dévoué
Messages : 601
Inscrit le : 19 janvier 2013
Version d'Excel : 2007

Message par julien35000 » 21 avril 2015, 17:52

excellent super merci :wink: :wink:
La seule chose qu'on est sûr de ne pas réussir est celle qu'on ne tente pas........
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'820
Appréciations reçues : 694
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR

Message par Steelson » 21 avril 2015, 18:31

Le calendrier est bien organisé, c'est super de travailler avec cela : les jours fériés dépendent de l'année (mais je n'ai pas vu de 1er mai), les mois sont bien des dates

Investis bien dans la compréhension des MFC à partir de cet exemple. Tu y gagneras en autonomie.
Idem sur la validation des données : il suffisait de rajouter de nouvelle années.

Tu es bien parti ... continues si je peux me permettre un conseil.

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
julien35000
Membre dévoué
Membre dévoué
Messages : 601
Inscrit le : 19 janvier 2013
Version d'Excel : 2007

Message par julien35000 » 21 avril 2015, 19:54

oui c'est exact 1mai férié!!!!! c'est bon j'ai rectifier erreur :D

Pour validation des données j'était partir pour modifier dans "formule/gestionnaire de noms" mais j'arrive pas logique après cou :D

Oui les mfc vont me servir pour bien apprendre sur beaucoup de points c'est bien.

J'ai encore a réussir a compter le nombre de jours posées quels qu'il soit par agents dans récap annuel mais sa c'est un plus pas obligatoire mais je vais m'amuser a le faire.

Sincèremement grand merci pour ton AIDE.

Julien
La seule chose qu'on est sûr de ne pas réussir est celle qu'on ne tente pas........
Avatar du membre
julien35000
Membre dévoué
Membre dévoué
Messages : 601
Inscrit le : 19 janvier 2013
Version d'Excel : 2007

Message par julien35000 » 21 avril 2015, 22:05

un conseil je doit passe par formule ou macro pour addittioner a chacun les jours de conges; recuo....

Cordialement
La seule chose qu'on est sûr de ne pas réussir est celle qu'on ne tente pas........
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'820
Appréciations reçues : 694
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR

Message par Steelson » 21 avril 2015, 22:15

Pour les calculs, je privilégie toujours la solution formule plutôt que macro ...
Dans ton cas, il faudra donc compter le nombre de fois où on rencontre "C", mais en excluant les samedis et dimanches !

Par exemple, pour Gérard en Janvier :
=SOMMEPROD((C4:AG4="C")*(JOURSEM(C$2:AG$2;2)<6))
Mais comme tu as tout regroupé sur la même feuille, il ne reste plus beaucoup de place pour mettre tout cela !

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
julien35000
Membre dévoué
Membre dévoué
Messages : 601
Inscrit le : 19 janvier 2013
Version d'Excel : 2007

Message par julien35000 » 21 avril 2015, 22:30

je souhaiterais avoir la recap sur la feuille recap annuel c'est la le probleme

=SOMMEPROD(Calendrier!C3:AG3;Calendrier!AK3:BO3;"C")
J'ai essayer sa mais erreur
La seule chose qu'on est sûr de ne pas réussir est celle qu'on ne tente pas........
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'820
Appréciations reçues : 694
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR

Message par Steelson » 22 avril 2015, 04:54

Ta formulation s'apparente plus à NB.SI ou NB.SI.ENS qu'à SOMMEPROD.
Donc remplace SOMMEPROD par NB.SI.ENS dont je ne suis pas familié !

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
julien35000
Membre dévoué
Membre dévoué
Messages : 601
Inscrit le : 19 janvier 2013
Version d'Excel : 2007

Message par julien35000 » 22 avril 2015, 08:00

bonjour toujours meme erreur :

"Vous avez tapé un nombre trop important d'argument pour cette fonction" :( :(
=NB.SI(Calendrier!C3:AG3;Calendrier!AK3:BO3;"C")
ou
=NB.SI.ENS(Calendrier!C3:AG3;Calendrier!AK3:BO3;"C")
La seule chose qu'on est sûr de ne pas réussir est celle qu'on ne tente pas........
Avatar du membre
julien35000
Membre dévoué
Membre dévoué
Messages : 601
Inscrit le : 19 janvier 2013
Version d'Excel : 2007

Message par julien35000 » 22 avril 2015, 08:28

=NB.SI.ENS(Calendrier!C3:AG3;"c")+NB.SI.ENS(Calendrier!AK3:BO3;"c")+NB.SI.ENS(Calendrier!C18:AG18;"c")+NB.SI.ENS(Calendrier!AK18:BO18;"c")+NB.SI.ENS(Calendrier!C33:AG33;"c")+NB.SI.ENS(Calendrier!AK33:BO33;"c")+NB.SI.ENS(Calendrier!C48:AG48;"c")+NB.SI.ENS(Calendrier!AK48:BO48;"c")+NB.SI.ENS(Calendrier!C63:AG63;"c")+NB.SI.ENS(Calendrier!AK63:BO63;"c")+NB.SI.ENS(Calendrier!C78:AG78;"c")+NB.SI.ENS(Calendrier!AK78:BO78;"c")
voici une réponse qui fonctionne.

Merci encore
La seule chose qu'on est sûr de ne pas réussir est celle qu'on ne tente pas........
Avatar du membre
julien35000
Membre dévoué
Membre dévoué
Messages : 601
Inscrit le : 19 janvier 2013
Version d'Excel : 2007

Message par julien35000 » 22 avril 2015, 13:22

dernière question dont je ne trouve pas solution.

Je veux veux verrouiller le calendrier seulement sauf laissé accès case vide du calendrier et l'appui sur les boutons de libre tout le reste verrouillé. sa fonctionne sauf que lorsque j'appui sur un bouton erreur :( .

Merci

oups c'est bon il fallait ajouter "format cellule"
La seule chose qu'on est sûr de ne pas réussir est celle qu'on ne tente pas........
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message